Skip to Content
0

Issue with RSPC_API_CHAIN_START Function Module

Dec 15, 2016 at 07:06 AM

105

avatar image

Hi All,

We have a PC scheduled to run on Sunday every week at 10 AM. On Monday I used

RSPC_API_CHAIN_START Function Module to trigger the process chain on a ADHOC request around 11 AM. The process chain got triggered but it got automatically scheduled on Tuesday 10 AM again and got triggered. Next schedule run also got scheduled for Tuesday 10 AM instead of Sunday. This is strange. Can you please help me in understanding why this has happened. Is this a known issue?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Ramesh Chegireddy Dec 15, 2016 at 10:09 AM
1

Hi Ashish,

Even i have faced this issue in my project with this FM "RSPC_CHAIN_API_START". Sometimes, after executing this FM, multiple scheduling jobs will get created along with the current run. So you need to check the Scheduled jobs in the Start variant, after execution of this FM.

The issue can be avoided by giving the "I_NOPLAN = X" . So while executing this FM , give your PC name and also mention "I_NOPLAN=X". So that no additional jobs will be created.

Thanks,

Ramesh

Share
10 |10000 characters needed characters left characters exceeded
sumeet durgia Dec 15, 2016 at 11:57 AM
0

Can you please check your schduling options what you have mentioned?

Share
10 |10000 characters needed characters left characters exceeded
Ashish Kumar Dec 16, 2016 at 04:28 AM
0

Hi Sumeet,

The PC was scheduled to run as a periodic job every Sunday. Period values were maintained as weekly. I was under the impression that the FM is not going to make impact on the next scheduled run which was on next Sunday 18th Dec. But it changed the scheduled job to Tuesday 13th Dec and got triggered.

Is this behavior of FM is known?

Thanks

Ashish

Share
10 |10000 characters needed characters left characters exceeded
Frédéric Cincet Dec 16, 2016 at 01:32 PM
0

Yes, it is a known behavior.

Use the parameter NO_PLAN as mentionned by Ramesh.

Regards,

Frederic

Share
10 |10000 characters needed characters left characters exceeded