Skip to Content
author's profile photo Former Member
Former Member

Mapping Error - IDoc

I get the following runtime exception in XI Monitor when mapping flat file data to ORDERS05 IDoc.

<b>RuntimeException in Message-Mapping transformation: Cannot produce target element /ORDERS05. Check xml instance is valid for source xsd and target-field mapping fulfills requirements of target xsd at com.sap.aii.mappingtool.tf3.AMappingProgram.start</b>

I've checked the following so far:

1) Succesfully tested the test data instance in Design.

2) Disabled the EDI_DC40 segment

3) Verified the sender and receiver agreements

4) Verified the data against the XSDs

Is there anything else I can check that indicates what is wrong?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Dec 16, 2004 at 07:12 AM

    Error can be due two scenarios.

    1.Is message mapping tested for the sample data in the integration repository?If not please test the message mapping in the Mapping Objects->messaging mapping of the Integration Repository.If the error is thrown in the test envirnonment of the integration repository then your target field mapping is not correct.The error might be either due to non-mapping of Mandatory elements in the target structure or nodes in the target structure are not assigned to empty constants(If the elements in any node is mandaory then the node needs to be explicitly initiated by mapping it to an empty constant).

    2.If the mapping is successful in the integration repository check in the integration directory if the "Apply control record values from payload" Checkbox in the Idoc Reciever Adapter deselected?(Integration Directory).

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sravya,

      Thank you for responding. The mapping tests out okay in the repository. I went into the directory to check the Idoc Reciever Adapter checkbox for "Apply control record values from payload", but did not see the checkbox. I'm working in 3.0 Does this option exist in 3.0 or am I looking in the wrong place. Thanks for your help.

  • author's profile photo Former Member
    Former Member
    Posted on Dec 17, 2004 at 09:06 PM

    Mark,

    In XI 3.0 the idoc adapter communication channel should have the checkbox "Apply Control Record Values from Payload".

    Dave

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      did you also try to reload the meta data for the IDOC adapter, e.g. call IDX2 transaction on the ABAP Stack and delete the existing idoc and create it again.

      This helped in my case where new fields did not show up in the mapping but in the test.

      May be worthwhile to tray.

      Cheers

      Stefan

  • author's profile photo Former Member
    Former Member
    Posted on Dec 18, 2004 at 10:26 AM

    Hi there,

    This is a longshot but are you actually mapping something to the top node /ORDERS05 ? If not, try mapping it and re-run your inbound message.

    Christiaan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 23, 2004 at 11:22 AM

    Maybe the problem is that you have disabled the mandatory segment for the idoc. Try to enable and assign constant values to mandatory fields.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.