Skip to Content
0
Former Member
Jun 16, 2011 at 06:43 PM

Error in Crystal Reports Runtime for VS 2008

492 Views

Hi, everyone...

I have an app that have some reports.

On my DevMachine, works fine. But when I deploy in ServerMachine (Windows Server 2003 R2 64), the app fails when I try to access a page that have a Crystal Report component.

Retrieving the COM class factory for component with CLSID {5FF57840-5172-4482-9CA3-541C7878AE0F} failed due to the following error: 800736b1.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Retrieving the COM class factory for component with CLSID {5FF57840-5172-4482-9CA3-541C7878AE0F} failed due to the following error: 800736b1.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[COMException (0x800736b1): Retrieving the COM class factory for component with CLSID {5FF57840-5172-4482-9CA3-541C7878AE0F} failed due to the following error: 800736b1.]

CrystalDecisions.CrystalReports.Engine.ReportDocument..cctor() +207

[TypeInitializationException: The type initializer for 'CrystalDecisions.CrystalReports.Engine.ReportDocument' threw an exception.]

CrystalDecisions.CrystalReports.Engine.ReportDocument..ctor() +0

test.Page_Load(Object sender, EventArgs e) +999

System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14

System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35

System.Web.UI.Control.OnLoad(EventArgs e) +99

System.Web.UI.Control.LoadRecursive() +50

System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627

I tried so many things, such as verify permissions, change registry and other stuff, without success.

I have installed on my server machine, the correctly (I think) version of Crystal Runtime

Please help me!

Thanks..