Skip to Content
author's profile photo
Former Member

SAP.Connector.RfcCommunicationException

When call SAPProxy function, a SAP.Connector.RfcCommunicationException raised

Please help me to analysis the cause and solution.

My doubt is if the Gateway is indispensible for a .NET Connector function call

Thanks in advance

Detail information:

Exception.Message:

Connect to SAP gateway failed\n

Connect_PM GWHOST=157.55.20.224, GWSERV=sapgw00, ASHOST=157.55.20.224, SYSNR=00\n\n

LOCATION CPIC (TCP/IP) on local host\n

ERROR partner not reached (host 157.55.20.224, service 3300)\n\n

TIME Thu Dec 09 13:13:01 2004\n

RELEASE 620\n

COMPONENT NI (network interface)\n

VERSION 36\n

RC -10\nMODULE ninti.c\n

LINE 979\n

DETAIL NiPConnect2\nSYSTEM CALL SO_ERROR\n

ERRNO 10060\n

RRNO TEXT WSAETIMEDOUT: Connection timed out\n

COUNTER 1\n

The code lines as following:

string cs = "ASHOST=157.55.20.224 SYSNR=00 CLIENT=000 USER=xxxx PASSWD=xxxxxx";

// construct the proxy with connection string

SAPProxy1 proxy = new SAPProxy1(cs);

// create a SAP Table variable

BRFCKNA1Table tblCust = new BRFCKNA1Table();

// call the RFM method on the proxy

try

{

proxy.Rfc_Customer_Get("","A*", ref tblCust);

}

catch(SAP.Connector.RfcCommunicationException exp)

{

MessageBox.Show(exp.Message);

return;

}

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Posted on Dec 09, 2004 at 08:21 AM

    There seems to be some(network) problem to connect your SAP server. Try "ping 157.55.20.224". If this works also try "telnet 157.55.20.224 3300".

    Might be that your SAP server is behind a SAPRouter. In this case you need to put the SAPRouterString in fron of the ASHOST parameter in connection string.

    Add comment
    10|10000 characters needed characters exceeded

    • RFC (and thus NCo) is just using TCP connection on port 3300+SystemNumber. Best test is allways "telnet <host> <port>". If this works, NCo should work as well.

      BTW: SAPGUI is using port 3200SystemNumber. If you use LoadBalancing via Message-Server you also need the MessageServer-Port. This is not fixed, but often it is 3600SystemNumber.