Skip to Content
author's profile photo Former Member
Former Member

XI 3.0 IDoc Adapter Problem

Hello,

I have a problem to establish an Idoc communication between SAP R/3 4.70 and SAP XI 3.0.

Following systems I have defined in XI SLD:

Sending R/3: HS3CLNT100

Receiving XI: X30CLNT100

In the Idoc (type orders) the sending port is "SAPHS3".

I have configured the XI 3.0 IDoc Adapter as follows.

- IDoc Port "SAPHS3"

- I have loaded the IDoc Metadata

- ALE Distribution model in sending R/3 is defined

- In the Integration Directory I have defined a "service"

This was done by upload an existing business system

"HS3CLNT100" including the automatic generation of

communication channels.

This should "normally" be all, what I have to define.

PROBLEM

========

When SAP R/3 tries to send an IDoc into SAP XI it will fail. In SAP R/3 transaction SM58 I can see following message:

"No service for system SAPHS3 client 100 in Integration Directory"

I don't think, it's normal to configure XI business systems with the same name as the IDoc port!?

Thanks in advance

Klaus

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Dec 05, 2004 at 08:56 PM

    Hi Klaus--

    Have you made an entry in the XI Repository for the business system which is sending the IDOC? This object could be under a party or service without party in the IR.

    Good luck!

    james

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.