Skip to Content
author's profile photo Former Member
Former Member

what's the problem?

Hey,all,I want to run the idoc server samples provided by SAP,I set the logon info and gateway info in the appropriate position,then I run the sample program,the result as following:

##################################################

Started MyIDocServer.

MyIDocServer is listening now...

Server exception occurred: com.sap.mw.jco.JCO$Exception: (129) JCO_ERROR_SERVER_STARTUP: Server startup failed at Fri Dec 03 13:52:06 CST 2004.

This is caused by either a) erroneous server settings, b) the backend system has been shutdown, c) network problems. Will try next startup in 1 seconds.

Connect to SAP gateway failed

##################################################

what's the problem?

In the begining,I think the problem is the gateway's not working,some basis friends tell me that: "If the R/3 instance is up and you can log on to it using the standard SAPGui, the gateway is up."

so I don't know what is the problem?who can tell me ...

Message was edited by: Leslie Zhu

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Dec 06, 2004 at 07:01 PM

    some times u need to give the gateway port no. (ex 3300) instead of name (ex 'sapgw'). i think this mapping is maintained in the hosts file.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.