Skip to Content
author's profile photo Former Member
Former Member

Layout Template - Alignment Problem

Hi,

I´m using EP6 Version 6.0.2.4.6 and made some Layout-Templates for my Pages. It works fine, but the alignment of the Ivies in it doesn´t match.

A short Example:

<%@ taglib uri="prt:taglib:com.sap.portal.reserved.layout.TagLibHtmlb" prefix="hbj" %>

<%@ taglib uri="prt:taglib:com.sap.portal.reserved.layout.TagLibLayout" prefix="lyt" %>

<lyt:template>

<hbj:content id="myContext" >

<hbj:page title="Portal Page">

<hbj:gridLayout id="GridLayout1" rowSize="2" columnSize="2" debugMode="TRUE">

<hbj:gridLayoutCell width="50%" rowIndex="1" columnIndex="1" horizontalAlignment="LEFT" verticalAlignment="top">

<lyt:container id="column1" />

</hbj:gridLayoutCell>

<hbj:gridLayoutCell width="50%" rowIndex="1" columnIndex="2" horizontalAlignment="LEFT" verticalAlignment="top">

<lyt:container id="column2" />

</hbj:gridLayoutCell>

<hbj:gridLayoutCell width="50%" rowIndex="2" columnIndex="1" horizontalAlignment="LEFT" verticalAlignment="top">

<lyt:container id="column3" />

</hbj:gridLayoutCell>

<hbj:gridLayoutCell width="50%" rowIndex="2" columnIndex="2" horizontalAlignment="LEFT" verticalAlignment="top">

<lyt:container id="column4" />

</hbj:gridLayoutCell>

</hbj:gridLayout>

</hbj:page>

</hbj:content>

</lyt:template>

When I look to a page with this Template, all my Iviews on it have an alignment on the right bottom corner of the cells. Is there no way to correct this? I tried a normal html-table but with the same result. Does anyone have a clue for this problem?

Regards,

Marcus

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Dec 02, 2004 at 10:11 AM

    Hi Marcus,

    the JSP looks fine for me.

    Probably you know http://help.sap.com/saphelp_ep60sp2/helpdata/en/d5/1b083e7623445ae10000000a11405a/frameset.htm

    The only thing where differences to the original layouts could exist seems to be the layout description within portalapp.xml, especially (and only?) the designClass value (prtlPageConR (right), prtlPageConL (left), prtlPageConM (mid) and prtlPageConF (full)). These css classes are defined within the themes, for example the most used will be under irj/root/portalapps/com.sap.portal.themes.lafservice/themes/portal/sap_standard/prtl_std/prtl_std_ie6.css, but they only define the margin and padding...

    Maybe you should copy a standard layout (from irj/root/WEB-INF/portal/portalapps/com.sap.portal.layouts.default) and start with this under new names; if they behave normal, start to manipulate them...

    Hope it helps

    Detlev

    PS: For better reading you can surround code / indentions with [ code ] and [/ code ] (without spaces). So checking the syntax would be much easier.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.