Skip to Content
author's profile photo Former Member
Former Member

Filter unassigned values in report output

Hi Friends,

I have a requirement as explained below.

There is a variable for Document Number with Select Options in the selection screen.

There are some documents which come as unassigned in BW, When I execute the query leaving this document no field blank it picks up all the blank document nos also and displays them as # unassigned.

I had tried by excluding # in the variable default value and also by Do NOt Include in selection in the query Designer, but it goes for a toss if the user changes in the Selection screen or removes the filter value in the Query Output.

Is there any way we can achieve following:

1. Even if user leaves this Variable as Blank, the report should filter out the # values.

2. If in case user enters # over there, report should not bring any output.

Objective is to hide the # Document Nos and user should not have any option to change in the query output.

can it be done by doing something in Variable exit or is there any other way.

would appreciate your help.

Regards

Deepak

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Dec 01, 2004 at 12:39 PM

    Hi Deepak,

    put the document number into the filter and restrict it to 'unassigned values' and exclude it from the selection. That should work.

    regards

    Siggi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Deepak,

      add a new characteristic to your cube, that is populated during the update rules. Fill it with 'O' = with Order

      or with 'N' = No order. Put this new characteristic into the filter and restrict your output to 'O'. If you don't want to reload your cube, implement this new characteristic as a virtual characteristic.

      Another option is, to restrict your query output to another characteristic that is only populated together with a order, if there is one.

      regards

      Siggi

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.