Skip to Content
avatar image
Former Member

Document number 0117 91133085 2010 was already assigned

Dear All,

While processing sales uploads am getting below mentioned error for number ranges.

Document number 0117 91133085 2010 was already assigned

Message no. F5152

Diagnosis

Document number 91133085 in company code 0117 and fiscal year 2010 has

already been assigned.

System response

Termination of processing.

Procedure

Check document number range 00 in company code 0117 and fiscal year 2010

and correct the number range status if necessary.

Please share any inputs.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 26, 2011 at 12:58 PM

    Hi,

    Check the current number range, In FB1N, let´s say that you have for example the following:

    No Year From Number To Number Current Number

    01 2009 0100000000 0199999999 0

    01 2010 0100000000 0199999999 100000280

    01 2011 0100000000 0199999999 0

    Are you still posting documents in year 2010?

    The case here is that when you have the 9999 year for the number ranges, when you delete it you should use the new number range starting from the latest number in use by the 9999 year.

    For example:

    You have 9999 year current document number 100000300, then you created 2011 number range that should be as follow:

    No Year From Number To Number Current Number

    01 9999 0100000000 0199999999 100000300

    01 2010 0100000301 0199999999 100000302 <<<

    In your case the system is trying to use a number which was already used by anoter number range and will raise the error message.

    You can try folow the instructions in note 741698 to reset the number range buffer:

    -> Call transaction SM56.

    -> Choose the menu option "Number Range Buffer -> Reset".

    A dialog box in which you can enter all the information is displayed.

    Caution: The generic entry is blank, not '*'.

    You must also set the "Global Reset" indicator; as a result, the system synchronizes all instances.

    I hope this helps.

    Best Regards,

    Vanessa.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      HI, Gurus

      I am getting this error. can any one solve this error. this is happened because of transport of number ranges transport from testing server to development Server.

      when i am trying to post vendor invoice document number taking earlier number instead of next number.

      I assigned Document type number 19 year 2011 from 200 001 to 280 000.

      "Document number "co.code" 200001 2011 was already assigned

      Message no. F5152

      Diagnosis

      Document number 200001 in company code "co.code" and fiscal year 2011 has already been assigned.

      System Response

      Termination of processing.

      Procedure

      Check document number range 19 in company code "co.code" and fiscal year 2011 and correct the number range status if necessary."

      I try SM 56, can any body suggest me what to correct in document type.

  • avatar image
    Former Member
    May 26, 2011 at 09:11 AM

    Hi,

    This is happening because the document number system is generated is already in system. You need to go to FBN1 > click on intervals and check the current number with the last document posted for that number range in the year 2010 & correct the current number based on the last document number generated in system.

    This happens mainly because

    1. Someone has reset the document number

    2. The document number ranges has been save in transport request and after posting some document the request got transported to production due to which document number has been reset to zero.

    Regards

    Milind Sonalkar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Your current number range is higher than what is generated for the sd document. If you have the FI document number range as external for the SD entries, then system takes the number range from the SD document. If this is the case then it seems that the SD relevant document has been used to post the other entries than the entries coming from SD & the number range for FI document has gone ahead of SD document number range. Check the setting for the document in FI.

      Regards

      Milind Sonalkar