Skip to Content
author's profile photo Former Member
Former Member

SAP BEx: Not enough cells Message when running Workbook

Hello There,

Today I found different message when I was running my Workbook. it appears only when I execute the workbook after opening the session on any Characteristic I would like to drill down.. after that .. the message never comes back.. here is the message below:

"SAP BEx: Not enough cells to display results" --

"To extend the results area to the right"

and I get 3 options as below

1. Overwrite existing cells

2. Insert cells next to the results Area

3. Insert entire columns..

and I did not find such message in RSRT.. Please let me know any work arounds and also please feel free to ask for further info --

Thanks alot

Mavi

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 01, 2004 at 02:01 AM

    Hi Mavi,

    First ... do not delete the current the layout by deleting rows. This will confuse BEx. Delete the layout by select all rows and selecting from Excel toolbar Edit >> Clear >> Contents.

    After that, just refresh the query and all should be fine.

    Regards, Pete

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Peter,

      I have encountered the same error because we have added extra rows beneath the results area using VB script. Your solution to clear these extra values works fine.

      However, we would like to automate this clear procedure so that it will occur BEFORE the actual refresh of results takes place.

      We have tired to clear these values in the SAPBEXonRefresh routine but this is exectued AFTER the results are returned and still returns the "Not Enough Cells" error.

      I imagine we can use the SAPBEXpauseOn/Off to pause the refresh, clear results, and then unpause to continue the refresh of results. We just don't know where to add this so that is will run BEFORE refresh occurs.

      Where can we add code to clear these extra values BEFORE the results are refreshed?

      Any help is greatly appreciated.

      Thanks,

      Adam

  • author's profile photo Former Member
    Former Member
    Posted on Nov 24, 2004 at 03:30 PM

    Hi Mavi,

    are you sure that this message doesn't appear only for the most obvious reason, that is your query (with all the chars drilled down) exceeds the maximum number of cells permitted in Excel (65536)?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2004 at 02:32 PM

    Hi Mavi,

    you can insert multiple queries in a worksheet. You also get this message when for example 2 queries are next to each other and you add a horizontal drilldown. A possible solution is to remove a queries from the workbook and reinsert only the ones you need. Be carefull with this approach if you use references in Excel. You might loose the references and have to redo the Excel work.

    Hope that helped,

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Peter & Michael,

      Thanks alot for your valuable comments.

      well, this workbook (with one query) (as it was) was working well before and I recently made some layout changes (exactly not remember).

      Is there any way to suppress that message or will it be good enough to delete the entire layout and re-design it..

      because the users don't want to see that initial message..

      Thanks for all the contributors..

      Regards

      Mavi

  • author's profile photo Former Member
    Former Member
    Posted on Nov 25, 2004 at 06:39 AM

    Mavi,

    You get the message because your results exceeded the permitted output size of Excel.

    Could you try the setting at Results area, right-click and select properties, follow by the column width, check 'adjust to whole columns'. I persume your current setting is 'adjust to results area'

    Regards,

    Lye

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Mavi,

      I get this message when I (or someone else) has added a row or column right next to the results table. (Perhaps they wrote their own Excel formula?)

      When the query refreshes, it makes sure that it does not over-write this sort of thing.

      You might not actually see anything because the "data" BW is about to over-write might be nothing more than blank spaces (a blank space is not a blank cell; it can be read as either text or numeric).

      Choose the option to "over-write" and everything should be fine.

      Regards, Pete

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2004 at 03:56 PM

    Hi Mavi,

    you cannot suppress the message on the SAP side. Check RSRT1 -> Messages.

    Try to supress the message in Excel -> options -> edit -> Alert before overwriting cells. Please post wether that worked. I would recommend to redesign the workbook anyway so you have a "clean" version.

    Hope that helped,

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 01, 2004 at 03:37 AM

    Mavi, I had another thought that you might find useful.

    Before deleting anything ... on the Business Explorer toolbar, select Layout >> Mark queries on worksheet.

    This should clearly illustrate what BEx thinks is part of the query and what BEx thinks is not part of the query. With this, you should be able to spot what it is that is infringing on the results area.

    Good luck,

    Pete

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks to all contributors who helped on this message.

      This problem been solved, and special thanks to Peter Knoer. I was able to fix the Workbook format error with his comment "Edit >> Clear >> Contents".

      any how, you all are going to benefit with Reward Points now.. lol 😊

      Thanks

      Mavi

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.