Skip to Content
avatar image
Former Member

regarding Adress command

Hi All,

When Iam printing the address for European Coutry customers Using FROMCOUTRY parameter in Address commmand. its displaying some Letter with hyphen before postal code. I dont want to print the letter with hyphen like 'A-'. Please tell me how can i suppress thsi value.

Many thanks

Edited by: krish.p on May 25, 2011 3:53 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    May 26, 2011 at 09:57 AM

    Hi,

    In that case, instead of using Address node, try and read the address from the table ADRC directly in the internal table.

    Loop at that table and write it using text element. Before writing that edit the hyphen sign and write it using text element.

    Thanks,

    Archana

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 26, 2011 at 01:15 PM

    Well, this is normally not a matter of taste.

    the ADDRESS statement formats the adress in a way according to the standard address format of this country.

    But if you still dont like it or know it better, then you have to print those fields manually as proposed above.

    Add comment
    10|10000 characters needed characters exceeded

  • May 26, 2011 at 03:45 PM

    You don't need to format the address manually. That indicator is the license plate code for the European standard address format. If you don't want it to show up, you need to check the 'Print country name' checkbox in the country code definition in the IMG.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 26, 2011 at 05:40 PM

    Further to what Brad said, the EU postal regs have a special format for when posting between member states. If the from and destination countries are flagged as EU members it uses the license plate code instead of the country. You can change this behaviour by changing the country settings in trn OY01. But the A- format is the correct one for Austria if the from country is also EU. It's just not what you may be used to.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 27, 2011 at 03:39 AM

    Hi ,

    That is the standard property of it. If you need that get manually and print .Just check the fields in address window and the table.

    Regards,

    Madhu.

    Add comment
    10|10000 characters needed characters exceeded