Skip to Content
0
Former Member
Nov 24, 2004 at 12:28 PM

Error when submitting a search term

19 Views

Hi,

I use SAP EP6 SP6 together KM SP6 and WebAS 6.40 and TREX 6.01.

I'm implementing a repository manager for a CMS, and everthing works fine within the KM browser.

When I enter a search term and press the submit button, the following error message is displayed

com.sapportals.wdf.WdfError

at com.sapportals.wdf.WdfCompositeController.buildComposition(WdfCompositeController.java:678)

at com.sapportals.htmlb.AbstractCompositeComponent.preRender(AbstractCompositeComponent.java:32)

at com.sapportals.htmlb.Container.preRender(Container.java:118)

at com.sapportals.htmlb.Container.preRender(Container.java:118)

at com.sapportals.htmlb.Container.preRender(Container.java:118)

at com.sapportals.htmlb.rendering.PageContext.render(PageContext.java:924)

...

--- Nested WDF Error -


java.lang.NullPointerException

at com.sapportals.wcm.control.search.SearchDialogControl.readConfiguration(SearchDialogControl.java:831)

at com.sapportals.wcm.control.search.SearchDialogControl.createNestedControls(SearchDialogControl.java:270)

at com.sapportals.wdf.stack.Control.create(Control.java:274)

at com.sapportals.wdf.stack.Pane.createControls(Pane.java:464)

at com.sapportals.wdf.stack.PaneStack.createControls(PaneStack.java:479)

at com.sapportals.wdf.stack.Pane.createControls(Pane.java:458)

at com.sapportals.wdf.stack.PaneStack.createControls(PaneStack.java:479)

at com.sapportals.wdf.WdfCompositeController.doInitialization(WdfCompositeController.java:268)

at com.sapportals.wdf.WdfCompositeController.buildComposition(WdfCompositeController.java:659)

at com.sapportals.htmlb.AbstractCompositeComponent.preRender(AbstractCompositeComponent.java:32)

at com.sapportals.htmlb.Container.preRender(Container.java:118)

at com.sapportals.htmlb.Container.preRender(Container.java:118)

at com.sapportals.htmlb.Container.preRender(Container.java:118)

at com.sapportals.htmlb.rendering.PageContext.render(PageContext.java:924)

at com.sapportals.htmlb.page.DynPage.doOutput(DynPage.java:237)

at com.sapportals.htmlb.page.PageProcessor.handleRequest(PageProcessor.java:109)

...

This also happens when I undeploy my repository manager application, so I don't think that this has something to do with my code. Also I'm not really sure if the search ever worked, since I tried it the first time to test if my repository manager content is indexed and found in the portal's search.

But when looking at the stack trace it seems to me that only standard rendering and configuration components belonging to the search iView are involved.

Does anyone have an idea where that error comes from and what might be done to get it working?

Thanks for any hint!

Regards

Torsten