Skip to Content
author's profile photo Former Member
Former Member

Logon to SLD

Hello people,

The developer reported to me the next error:

com.sap.tc.webdynpro.services.exceptions.WDTypeNotFoundException: type com.sap.demo.flight.types.Bapimaxrow could not be loaded: com.sap.dictionary.runtime.DdException: TypeBroker failed to access SLD: Error while obtaining JCO connection: com.sap.sldserv.exception.SldServiceRuntimeException:

Failed to create CIM client

.

We have read the guide "Handling Transactions with BAPIs in Web Dynpro" and we are configuring the SLD then.

I have the guide about SLD configuration but I have some

problems with part 3.2 COnfiguring users.

When I call http://server:50000/sld, I don´t know the user and pwd. I tried with J2EE-ADMIN but it reported me

No Authorization. I don´t hace any user like Administrator or Admin.

When I installed WAS JAVA add-in, I select No SLD available during the installation. But I could see the service and it is active.

The guide talks about users and groups (roles on R/3) but I don´t have anything.

I would like to logon to the SLD.

Could you assist ??

Thanks in advance.

Regards

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 29, 2004 at 05:15 AM

    Hi Andrea,

    Which SLD are you trying to connect to. i have faced the similar problem that you have reported. Is it possible to have a netmeeting session to see the problem. Please reply back to chander.s@sap.com

    Regards,

    Chander

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Andrea,

      Glad you could finally get your problem resolved. Now as to next problem regarding login to Content Administrator.

      You have said that you cannot logon to the http://<host>:<port>/useradmin because you do not have the login. As for the register functionality as far as i know the register link will only create a new user for you and assign it default roles which will not be sufficient to logon to Content Administrator.

      After the user regsiters the administrator has to go and assign some roles to that user using the useradmin. Hence Register will not help in this case.

      What you can do in log in to the Visual Administrator as before and under Server -> Services -> Security provider from here you can create a new user by clicking on the user management tab. This user also gets created in the UME.

      Once the user is created in the same tab User management serach for the just created user. Select it and click the Group button. Then assign the group Administrators to that user and try logging in to the Content Administrator.

      It worked in my case. Hope it works in your case too.

      Regards

      Sidharth

  • Posted on Nov 23, 2004 at 03:40 PM

    Hi Andrea,

    You must be having some user having Administrator rights. Using this user log in to the Visual Administrator. The in the services find a service named Security Provider.

    In the Policy Configurations Tab look for a component name sap.com/com.sap.lcr*sld. Select it and under Security Roles tab select LcrInstanceWriterAll.

    Now search for a particular user

    say this current user using which you have logged on to Visual Admin and click Add.

    Now just login to http://localhost:57000/sld using this user and pwd.

    You will be able to log in. However for this procedure to work you should have a user id for Visual Adm.

    Hope this is helpful

    Regards

    Sidharth

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Ram,

      Have you done the basic settings in SLD. What i mean is that have you set the object server and the data supplier bridge under Administration -> server settings and Administration -> Data supplier bridge. Also you need to start the SLD server after setting the object server.

      The object server name is the host name of the machine on which J2EE engine is running.

      Then in CIM client generation settings and HTTP settings you need to give the host name (name of the server on which J2EE server is running) port 5XX00 XX - instance number and the user and password.

      username - Administrator (WAS Java instance)

      and password that you have given during installation.

      Hope this helps

      Regards

      Sidharth

  • author's profile photo Former Member
    Former Member
    Posted on Dec 10, 2004 at 07:19 PM

    Hi Andrea,

    You had some good answers, but did you forget to give points? It's a way to say "thanks".

    See: </people/mark.finnern/blog/2004/08/10/spread-the-love for directions.

    Click on the Yellow Star icon in each reply.

    You can give:

    1 - 10 pointer (solves problem, marks as answered)

    2 - 6 pointers (very helpful)

    Lots of 2 pointers (helpful)

    This time I did it for you, but you can change it.

    Cheers,

    Linda (and Mark Finnern)

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.