Skip to Content
author's profile photo Former Member
Former Member

SAP XI Adapter: XI - Does it understand Message Protocol XI 2.0

Hello everybody,

first of all, system description:

We're using Sap Exchange Infrastructure 3.0 - Support Package 9

We are trying to communicate with SapXi through the XI Adapter. Now the problem:

Our Adapter, which sends a message to XI only "speaks" the old Message Protocol "XI 2.0". As the XI Adapter acting as a Receiver (XI is sending to our Adapter) is able to switch between the Message Protocol "XI 2.0" and "XI 3.0" we're wondering if this also possible if our adapter sends messages to the XI Adapter?

Another problem is the basic authentication. At the moment I'm not able to connect to the right client-id through a browser. If I send a HTTP-Request to http://host:8000/sap/xi/engine?type=entry i'm not able to login with various users (which are client100-users). I also tried port 8100 but it seems to be a redirect to port 8000.

Has anyone some infos on that? I tried to find some in the online-help but I can't find any documentation regarding the XI Adapter.

With regards

-Sascha Vogt-

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 23, 2004 at 02:10 PM

    Hi Sascha,

    In the channel definition for the XI adapter you can choose which message protocol is used: XI 2.0 or XI3.0.

    For your second problem, in the HTTP-Request you can add the userID, password, namespace, client etc. For example:

    http://ipaddress:8000/sap/xi/adapter_plain?namespace=http://SAP.com/test∫erface=IOA_OrderPlacementRequest&service=Test∂y=&agency=≻heme=&QOS=BE&sap-user=xiappluser&sap-password=xipass&sap-client=100&sap-language=E

    Hope this helps.

    Cheers,

    Frank

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Stefan Grube

      Hi Stefan,

      >You need not to create a sender channel for XI protocol. >The XI 3.0 identifies from the SOAP message the XI >version.

      That was the answer I wanted to get 😉 Thx a lot.

      I did some more configuration and left the Party-fields blank, so the definied Business Services appeared under "Service Without Party" and stripped the party-parameters in the http-request. Now it works perfect.

      I guessed that Frank proposed something using another adapter, but as this one didn't understand the soap-message I tried it with the engine. Now I know what the issues behind are.

      Best regards

      -Sascha-

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.