Skip to Content
avatar image
Former Member

Oracle password


I just installed oracle 10g using the sapsever.cmd, it prompted me to set an SID at the DOS prompt but it didnt prompt me to set a password. When i wanted to log in to sqlplus to check and probably increase my java pool size am been prompted for a pass word.

How do i resolve this? I have search the forum but couldnt get an answer.

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

11 Answers

  • May 21, 2011 at 11:22 AM

    Hi,

    Did you try to call sqlplus as Administrator ?

    That won't work.

    Login as sidadm to windows and

    sqlplus / as sysdba

    should work (at least after sapinst did finish).

    Volker

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 21, 2011 at 11:32 AM

    Thanks volker,

    I have not started the sapinst, i wanted to increase the java pool size first since that has given me problems in previous attempts.

    When i tried entering sqlplus as 'sysdba' am being prompted for password

    And my oracle installation didnt prompt me to set any password while installing it.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      >> I have not started the sapinst, i wanted to increase the java pool size first since that has given me problems in previous attempts.

      When i tried entering sqlplus as 'sysdba' am being prompted for password

      It is normal that the oracle installation did not ask for an admin password during the RDBMS installation. The database users will be created during the SAP installation. You didn't perform sapinst means that you didn't create a database on the system. So it means that you don't have a spfile or init<SID>.ora file. Under this circumstance where do you planning to enter this value?

      If you have spfile or init<SID>.ora files, rename spfile and complete missing parameters, including java pool size parameter in the init<SID>.ora file.

      As the other guy noted that you will be able to access to the db resources by sysdba role, after the respective SAP installation and logging in to the system, by <sid>adm user.

      Best regards,

      Orkun Gedik

  • avatar image
    Former Member
    May 27, 2011 at 11:33 AM

    Hi,

    If you want to increase your JAVA pool size, you can change it directly by pfile.

    After those changes if you want to restart database:login as

    > sqlplus "/as sysdba"

    shutdown ;

    and then startup open;

    Now it should solve your problem....

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 30, 2011 at 10:44 PM

    I wanted to increase the shared pool size of my oracle database from 176M to 400M but when I execute (as advised above): alter system set shared pool size=1235 it shrinked to 92M

    please what is the right way to use the alter system set' command to increase shared pool size?

    shared pool reserved size has a value '18103664

    I dont want this size to cause problem for my(on going) ECC 6.0 installation

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Bryne,

      shared pool size should be "419430400" in order to set to 400M. Please find the examples, below;

      alter system set shared_pool_size=419430400 scope=spfile;
      

      or

      alter system set shared_pool_size=400M scope=spfile;
      

      or change it in the init<SID>.ora, manually.

      Best regards,

      Orkun Gedik

  • avatar image
    Former Member
    May 31, 2011 at 02:37 PM

    I need to change my shared pool size from 176M to 400M but when I issued alter system set..... it didnt change then i checked and discovered that my sga-max size is actually 384M but this too will not change. So I issued show parameter SPFILE but instead of SPFILE value it returned the following variables

    restorespfile; and

    spfile

    both without values, what is the way out please (there is actually no spfile on my C:).

    Thanks.

    Bryne

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Bryne,

      If your database do not have an SPFILE, it will use init<SID>.ora profile file, under "<drive>:\oracle\<SID>\<version>\database" path. So, you can set the parameters in this file. If you would like to create an spfile, shutdown your instance and execute the statements, below;

      connect "/as sysdba"
      shutdown immediate;
      startup nomount;
      create spfile from pfile;
      

      Then startup your database. From now on your system will start to use SPFILE instead of init<SID>.ora file.

      The rule is easy, if the system has an SPFILE, Oracle read it, even init<SID>.ora file exist on the system. If SPFILE is not exist, Oracle read init<SID>.ora file.

      Best regards,

      Orkun Gedik

      Edited by: Orkun Gedik on May 31, 2011 5:58 PM

  • avatar image
    Former Member
    May 31, 2011 at 03:40 PM

    Thanks for your prompt response Orkun, I really appreciate it. The spfile has been created and I have effected my changes.

    I am very grateful, i will now resume my IDES installation and get back with feed backs.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 01, 2011 at 09:42 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Bryne,

      >> SOLUTION: Make more disk space available.

      The system indicates the solution 😉 Add more storage to the system

      Best regards,

      Orkun Gedik

  • avatar image
    Former Member
    Jun 01, 2011 at 10:10 AM

    sorry experts dont bother about the question above it is resolved.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 01, 2011 at 10:35 AM

    Thanks for your usual prompt response Orkun.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 03, 2011 at 11:45 AM

    @ all thanks...I just successfully completed my SAP ERP 2005 SR central instance installation.

    @Orkun Gedik special thanks for your assistance!

    Question: is there any post lnstallation config i must do before commencing study with it, note it is AS ABAP only.

    Add comment
    10|10000 characters needed characters exceeded