Skip to Content
author's profile photo Former Member
Former Member

Error with max number of rows (using lookupV)

Hi experts!

I'm using Xcelsius 2008 SP3 FP3.5 with live office sp3 fp 3.5.

I hacve configured xcelsius options so the maximum number of rows allowed would be 2000, instead of 512.

I have a webi report with a 1500 rows. I imported it via Live Office in my presentation.

I have several formulas using lookupV. At design mode, it's ok. In preview,

when data is in the first 512 rows, everything is fine. When not, returns #N/A error.

I've tried using other excel functions such as index, match, with the same result.

I've checked at Xcelsius preferences and it is set to 2000 rows.

Xcelsius doesn't warn me about truncate.

Any ideas please??

Thanks in advance!

Regards,

Sergio

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on May 23, 2011 at 04:57 AM

    into the Xcelsius itself, go to your liveoffice connection in xcelsius(Manage Connections), and select your liveoffice connection

    into the definition tab, find something called "Grid" into the Ranges List

    click grid, and then bind it to wider range instead of 512, make it 2000 or something

    good luck

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I've been researching today for notes. I've found three of them very intersesting.

      1203972 - VLOOKUP works in Excel but not in Crystal Xcelsius

      1257233 - How to increase the number of rows and columns fetched in Xcelsius from Live office.

      1300927 - What are the supported excel functions in Xcelsius 2008?

      I think that applying these notes I'll make it work (i really hope so, at least!)

  • author's profile photo Former Member
    Former Member
    Posted on May 23, 2011 at 02:04 AM

    Sergi,

    When in preview mode, click on File > Snapshot > Spreadsheet, then open that in Excel (after closing Xcelsius).

    Does this shed any light on the matter? Can you see what the formulas are showing?

    Or have you already done this?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 08, 2011 at 11:32 AM

    Hey Firend

    I also faced the same issue, but it is resolved now

    Rows 512 are default view for the live office object, no matter you have edited in the xcelsius->preferences->excel rows

    to edit the default view of 512 rows of live office you have to edit one of the file on Bo tomcat server

    We had to change the Lifeoffice_config.properties file inside dsws-liveoffice-ws.jar that's found in c:\program files\business objects\tomcat\webapps\dswsbobje\WEB-INF\lib.

    In the file u will found the field named as default view in live office rows :512 rows

    chagnge it to number of rows as per your need.

    I hope this will help you, because it helps me a lot 😊

    Thanks!!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.