Skip to Content
author's profile photo Former Member
Former Member

Caching problem one

Hi,

I have written a small function with two input variables:

Begda and endda.

Both variables are marked as mandatory in the R/3 backend. Now I have used it in a VC. In the test function both variables are marked as mandatory.

So fare so good...... 😊 but

now I have changed theses both parameters to optional. Save and activate it in the backend.

When test the function now in the test function. Nothing has changed.

I have checked following:

  • reconnect to the portal -> (no change)

  • refresh the functions in the data services -> (no change)

  • reread the function -> (no change)

Only when I change the name of the function in the backend, I got the change in the parameters.

Any idea ? Is there any update flag in the portal I have to set ?

Best regards Hans Georg

But when I test the function in the test

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Nov 23, 2004 at 03:59 PM

    Hi Hans Georg,

    In order to change the connection life-time do the following:

    1. find the sda com.sapportals.connectors.sap.sda in your installation. (it should be at \usr\sap\S96\JC00\SDM\root\origin\sap.com\com.sapportals.connectors.sap\SAP AG\609.20040921091607.0000

    2. Open the sda

    3. Open the SAPCFConnector.rar

    4. Open META_INF/connectoe_j2ee_engine.xml for editing

    5. Edit the <connection-lifetime> property (the units are seconds)

    6. Redeploy the SDA

    7. Restart J2EE

    8. To confirm that the change was made open the admin tool, Open Server -> Services -> Connector Container -> Connector ->Connector1.0 -> …/SAP connector ->ManagedConnection Factory Tab -> Connection Definition Tab, check that the connection life-time is changed.

    Regards,

    Lisi

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 21, 2004 at 10:27 AM

    Hi Hans Georg,

    If you didn’t change the connection lifetime in the J2EE admin tool, you are probably working with the default, which means that the connections you open to the backend are never closed. As long as you work with the same connection, the data will be retrieved from the cache.

    If you want to disable the cache, you need to set the “connection-lifetime” property in the J2EE. The way to do that varies from one J2EE version to the other, so I will be able to instruct you how only after you specify the version you are working with.

    Regards,

    Lisi

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.