Skip to Content

Content of Business Object ZBUS2007 disappeared partially

Hi all!

We have a problem with business object ZBUS2007 (Work Order). It was created as sybtype of BUS2007 and delegation BUS2007 - ZBUS2007 exists.

During the last few months the following problem occured twice in ZBUS2007.

In a first case, some events disappeared from ZBUS2007.

In a second case, a piece of code of one method disappeared from the program.

Of course, in both cases nobody deleted them. They just disappeared and we had to add them again.

May be somebody has any idea what happened?

May be it is because of large number of avents and attributes? There are 104 attributes added to ZBUS2007 and 260 events added.

And one more question.

Is there some way to check "Where used" for attributes and events?

Thanks,

Nina.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on May 19, 2011 at 08:37 AM

    Hi,

    sounds more like transport issues.

    Although the amount of events is huge I don't see why this should cause any problems, if they keep returning try to create a reproduceable error and raise an error at OSS.

    Instead of checking SWE2 for event linkages which is cumbersome due to the huge number of events, you can also query the table directly SWFDEVTYP

    For used attributes maybe one of the SWD* tables

    Kind regards, Rob Dielemans

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 20, 2011 at 12:54 PM

    Dear Nina,

    I would also say that the huge no. of events and attributes should not have an impact on the missing events and code.

    This seems more like a transport problem. As in case of workflows we have to be very sure that all the related objects are transported correctly including both customizing and workbench objects.

    It is always suggested to first transport the workbench request and then the customizing request. Then a buffer refresh should be done to sync the workflow in the new system.

    If the correct transport procedure is followed and the workflow and BO version remain consistent across landscape (D, Q and P box), then I don't see that you would face this issue again.

    Regards,

    Saumya

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 22, 2011 at 08:25 AM

    Hi ninakor ,

    Go to the table E071 and enter your Business object name in table field 'OBJ_NAME' and execute it.

    Table will show you the list of Transport request's that is having your business object.

    So using this Transport request's check whether any changes has been made in the businee object.

    Thanks,

    Viji.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.