Skip to Content
avatar image
Former Member

Cannot start JSMP tool - Can start SDM

Dear all,

We do have the following environment :

1. PL7 is our productive BW-ABAP system

PL8 is our productive BW-JAVA system

PL7 acts as PL8 UME.

2. QL7 is our quality BW-ABAP system

QL8 is our qulatiy BW-JAVA system

QL7 acts as QL8 UME.

We have copied PL7 to QL7 and PL8 to QL8 (system refresh for ABAP, export/ import of schema for BW-JAVA).

Now, we cannot restart the JSPM tool from QL8.

We do have the following issue :

1. When starting QL8, we do have the following error in std_server0.out file :

May 16, 2011 3:04:53 PM com.sap.ip.bi.webapplications [SAPEngine_Application_Thread[impl:3]_28] Fatal: Error in DoInit method

May 16, 2011 3:04:53 PM com.sap.ip.bi.webapplications [SAPEngine_Application_Thread[impl:3]_28] Fatal:

May 16, 2011 3:04:53 PM com.sap.ip.bi.webapplications [SAPEngine_Application_Thread[impl:3]_28] Fatal: java.lang.reflect.UndeclaredThrowableException

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sapportals.portal.security.usermanagement.WrappedUserInvocationHandler.callOtherMethod(ServiceUserFactoryImpl.java:172)

at com.sapportals.portal.security.usermanagement.WrappedUserInvocationHandler.invoke(ServiceUserFactoryImpl.java:147)

... 30 more

Caused by: com.sap.security.api.PrincipalNotAccessibleException: ORA-00942: table or view does not exist

at com.sap.security.core.imp.AbstractPrincipal.getPrincipalDatabagValues(AbstractPrincipal.java:1797)

at com.sap.security.core.imp.AbstractPrincipal.getAttributeValueString(AbstractPrincipal.java:1843)

at com.sap.security.core.imp.AbstractUserAccount.getDisplayName(AbstractUserAccount.java:2316)

at com.sap.security.core.imp.UserAccountWrapper.getDisplayName(UserAccountWrapper.java:509)

at com.sapportals.portal.security.usermanagement.User50_Impl.getDisplayId(User50_Impl.java:222)

... 36 more

May 16, 2011 3:05:05 PM com.sap.lcr.cimsrv.CIMOMServlet [SAPEngine_Application_Thread[impl:3]_15] Fatal: SLD initialization failure, can not set up cluster-wide event notification. Please check your JMS provider for errors.

  1. Excluding compile: com.sap.engine.services.webservices.jaxrpc.encoding.GeneratedComplexType::_loadInto

  2. Excluding compile: com.sap.engine.services.webservices.jaxrpc.encoding.InstanceBuilder::readElement

2. When starting JSPM, we do have the following error :

"Can not detect usages. Cannot detect installed ppms instances. Could not load usage type data from source jdbc/pool/QL8.

"com.sap.sl.ut.infoprovider.exceptions.UTInforException: Wrong SQL Statement!

"com.sap.sl.ut.infoprovider.exceptions.UTInforException: Wrong SQL Statement! java.sql.SQLException: ORA-00942: table or view does not exist."

Important :

we can use SDM, Visual Administrator and Configtool without any problem.

Any help is very welcome.

Best regards

SAPNetWeaverAdmin

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    May 16, 2011 at 06:19 PM

    1. ORA-00942: Class PrincipalNotAccessibleException this is a UME Exception, Have you performed the Post Installation Steps after J2EE System Copy --> UME Configuration using Config TOOL & Under core.ume.service?

    2. SLD initialization failure, Visual Admin --> SLD Data Supplier, Check the user and the port of the Central/ Local SLD and hit a the Menu Arrow which has 'Refresh the data from SLD'.

    3. Cannot load JSPM, this is also related to Post Installation Steps of J2EE.

    Thanks

    SM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Did you solve your issue. We are encountering the same problem and would like to know how to solve it.

      Thanks in advance.

      Best Regards,

      Olivier

  • avatar image
    Former Member
    May 16, 2011 at 07:05 PM

    Hello

    Kindly check the JSPM log under /JSPM/log and see what other information can be seen.

    Kindly cross check all the post activities.

    I hope SLD supplier data has some issue along with UME configuration.

    Kindly fix the UME part so that ABAP and Java are in sync for user management part.

    Then fix the SLD connectivity and try.

    Regards

    Vivek

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 16, 2011 at 10:18 PM

    Hi,

    Check whether you have installed the correct java version and JCE policy files or not.

    Thanks,

    Deepthi

    Add comment
    10|10000 characters needed characters exceeded