Skip to Content

User session (HTTP/SMTP/..) closed after timeout

Hi Experts,

Web Dynpro ABAP application is getting called from Portal as soon as the user logged to the portal. i.e., As soon as the user logged to the portal, first iView which is displayed is Web Dynpro iView. But a strange error I can see is that at some times after login I get the following error.

Error when processing your request 
What has happened? 
The URL http://<hostname>:8000/sap/bc/webdynpro/sap/<appname>/ was not called due to an error. 
    
Note 
The following error text was processed in the system SID : User session (HTTP/SMTP/..) closed after timeout 
The error occurred on the application server hostname_SID_00 and in the work process 0 . 
The termination type was: ERROR_MESSAGE_STATE 
The ABAP call stack was: 
Method: PREPROCESS_REQUEST of program CL_WDR_CLIENT_ABSTRACT_HTTP===CP
Method: IF_HTTP_EXTENSION~HANDLE_REQUEST of program CL_WDR_MAIN_TASK==============CP
Method: EXECUTE_REQUEST_FROM_MEMORY of program CL_HTTP_SERVER================CP
Function: HTTP_DISPATCH_REQUEST of program SAPLHTTP_RUNTIME
Module: %_HTTP_START of program SAPMHTTP

This error in general comes when the user session expires after logged in and left the application idle for some time. But in my scenario this happens as soon as user logged into the portal. I found a notes 882548 ,1578632. But are not applicable in my case there is no parameter rdisp/plugin_auto_logout set in the profile.

Any suggestions to avoid this error.

Thanks

Murthy.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    May 24, 2011 at 11:59 AM

    Hi Chinna,

    Check the WAS Profile with transaction rz10 / rz11

    Check parameter- icm/server_port.Try to set the TIMEOUT to eg 600. default is - icm/server:port0 PROT=HTTPS, PORT=443, TIMEOUT=300

    And, restart the server.

    Add comment
    10|10000 characters needed characters exceeded

  • May 29, 2011 at 11:04 AM

    Dear Murthy,

    Hope you are doing good.

    Try following in order to avoid the timeout:

    1) refer to note 824554 and check whether increasing the ICM parameter helps to prevent the timeouts. Either set the parameter for icm/server_port_0 or increase icm/keep_alive_timeout (sec.) from 600 to 10000.

    2) in the system settings change the profile parameter ms/http_timeout and ms/https_timeout to higher values.

    3) Regarding the parameter rdisp/plugin_auto_logout, refer the blog: [BSP In-Depth: Confusion between Stateless, Stateful and Authentication]

    (Timer: Session Management, Timer: HTTP Request Processing Time).

    4) Set: icm/HTTP/esid_response_check = TRUE in the backend system, restart the server and perform a new test.

    Thank you and have a nice day :).

    _____________

    Kind Regards,

    Hemanth

    SAP AGS

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 10, 2011 at 12:50 PM

    1) Increase icm/keep_alive_timeout (sec.) from 600 to 10000. Refer to note

    824554.

    2) In the system settings change the profile parameter ms/http_timeout and

    ms/https_timeout to higher values.

    4) Set: icm/HTTP/esid_response_check = TRUE in the backend system

    Restart the Server.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 26, 2011 at 07:01 AM

    I dont have any idea now. Search google

    Add comment
    10|10000 characters needed characters exceeded