Skip to Content

Table UI

Hi,

I have a table UI on the view. I have set the selection mode of table UI to none. However i still able to select a row of the table UI. I mean when i take the cursor over the table UI it changes to kind you have when you take the cursor over to a hyperlink (i am sorry i dont know th exact terminology there).

I tried making the property of the context node i.e. InitializeLeadSelection to false. Yet this does not work.

How can i disable te above as it indicates that by clicking a table row some action may happen.

Regards

Sidharth

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 15, 2004 at 10:41 PM

    Seems to be a bug. Which version/client are you using?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Sidharth Deshpande

      Hello,

      Armin's point is that we implemented a new rendering a while ago. This rendering takes the freedom to do a server roundtrip on certain occasions. For historical reasons, one such occasion is nearly every click in a table. In fact, the table data source's lead selection is always changed to denote the currently selected row, even if selection mode is NONE. <b>There is nothing you can do about this!</b> This behaviour is necessary in case you have buttons in your table and your button's event handler would like to know the row of the button clicked by the user.

      We will improve the table's behaviour in the next release.

      Best regards,

      Thomas

  • author's profile photo Former Member
    Former Member
    Posted on Nov 16, 2004 at 09:52 AM

    Hi Siddarth

    I tried so many ways to achieve this but only thing that seem to work is to set the enabled property of the table to false but this would mean that you cannot enter anything.

    Regards

    Pran

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.