Skip to Content
May 13, 2011 at 05:59 AM

XL Reporter fails to start Excel if RDP user is not an administrator



I have been struggling for a week with this problem.

We are running SAP B1 2007 SP1 PL08 on windows server 2003.

We have the SAP B1 client running on Windows Server 2008 R2 RDP (terminal server) as a remote app.

Excel 2007 is loaded on the RemoteDesktop server (Terminal server)

When a standard domain user is running SAP B1 as a remote app and attempts to open an XL report we get the error message

"Security Settings in Microsoft Excel Prohibit XL reporter from running"

I know this message has been covered before and I know the fix (when not using SAP as a remote app) is to tick the check box in the Excel trust centre "Trust access to VBA object model"

This works on standard client install, i.e SAP B1 client loaded on the users machine.

This is done and many permutations of various settings in the trust centre have been tried.

The only way we can get Excel to open when selecting an XL report from SAP B1remote app, is to put the remote user into the local administrators group on the RDP server (terminal server), however this is not appropriate. So does anyone know what setting I am missing. It seems to be some permision related thing , the Error message seems to be not entirely acurate.

I have tried giveing remote_desktop user full permissions to the entire drive on the RDP (terminal server) where Excel and SAP are located but getting no where.

Our Support organisation to which we pay a support fee too is unable to solve this issue after 1 week of waiting.

Any help would be greatly appreciated.