Skip to Content
author's profile photo Former Member
Former Member

Protect workbook from authorized user

I have created a workbook Z_WB_TEST in BEx Analyser. I want to protect my workbook so that authorized user can't do modification in my wookbook. I want othe user can only change variable value and run that workbook and save it. Other than this he should not do any changes like delete, hide row column etc.

I want this type facility because a user will provide me report after executing workbook Z_WB_TEST.

Kindly help me.

regards

nk

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on May 12, 2011 at 02:29 PM

    Best Practice is to break them down. End users/Power users get Reporting component roles that have the access to run queries. Workbook roles provide access to developers for publishing their workbook queries/reports and this would make sure that end users would not be able to change and overwrite the existing format.

    Third set of roles would be the analysis auth roles which provide the actual access. A 3 way naming convention in BW always helps the security to keep it tight and simple.

    ~Sri

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 12, 2011 at 03:39 PM

    The Object S_USER_AGR controls access to the workbooks and folders (roles created as folders). Once you have created your workbook, save it to a role folder (you should have the role folder assigned to your user ID in order to save the workbook to it). you should have access to S_USER_AGR where as the other users whould be assigned the role in which you have saved the workbook, BUT NO ACCESS to object S_USER_AGR.

    This way, they can open up the work book change the variables on the selection screen (depending on the analysis authorizations that are assigned to them) and execute the report.

    Please note that for the workbook to refresh everytime with current date you need to toggle a setting on Bex Analyzer.

    Regards,

    Prashant

    Edited by: Prashant Pasala on May 12, 2011 9:11 PM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.