Skip to Content
author's profile photo Former Member
Former Member

DB Connect MS SQL Server

My users needed to get data from another legacy system, which was implemented on SQL Server 2000, to show on their reports. I've tried to connect to the SQL Database by using DB Connect on BW 3.0B.

Here is my BW Spec.

1. App. : BW 3.0B

2. DB : Oracle 8.1.7.3.0

3. Patch : 10

4. OS : Windows 2000 Advance Server

Here is my SQL Server Spec.

1. SQL Server 2000 (No Patch)

2. Windows 2000 Advance Server

And Here is what I've done.

1. Installed SQL Server 2000 [client] on BW server.

2. Installed LIB_DBSL.SAR on BW Server

3. Installed DW.SAR

4. AT DataSource (RSA1), DB Connect has been selected and these have been configured

4.1 Logical System = MSSSQL

4.2 DBMS = MSS

4.3 User Name = MEAW (which has DDL Admin. Authorization)

4.4 Conn.Info = "MSSQL_SERVER=10.0.46.22 MSSQL_DBNAME=ICC"

5. Created Communication Structure

6. Assign DataSource to communication structure by using target table in MS-SQL Server 2000.

Currently I can see the target table and also can see content in that table from BW side BUT I cannot upload data to BW. Everytime I started uploading, system always prompt error...

1. Error in source system

2. No mapping available for DataSource 6DB_TSO_INTAUDIT_DET. Assign an InfoSource.

Could you guys please help and suggest what I have I been still missing.

Even I have checked the SAP Note No. 512739

Thanks and Regards,

MN

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 09, 2004 at 06:57 AM

    Hi,

    did you generate the datasource based on your target table? Do you have authority to select data from that table?

    I would generate the datasource and reactivate the transfer structure and transfer rules. That should work.

    regards

    Siggi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks for ur prompt reply.

      I did generate the datasource & transfer structure (6DB_TSO...) and I can access the table from my login.

      I'm able connect to SQL from BW and also see the data.

      But the problem occurs while try to load from infopackage.

  • author's profile photo Former Member
    Former Member
    Posted on Dec 02, 2004 at 06:56 AM

    Hi,

    let me ask you if you were able to resolve the problem? Yesterday I fell into the same troubles with similar configuration (BW based on Oracle).

    I did several attempts with the same error: BW3.0/BW3.1 with different patch levels, different MS SQL servers with/without support packs, different SQL users/tables/views/rights.

    I believe it is something with the DBSL because I am able to get the data into BW when I connect to (external) Oracle database (such a connection uses the "primary" DBSL, not that one which was installed later).

    Thanks for ANY answer.

    Zbynek Halousek

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.