Skip to Content
avatar image
Former Member

PI Impact - SNC upgrade from 5.1 to 7.0

Hello All.

I have the requirement where SNC system in the landscape is upgraded from 5.1 to 7.0 . In PI7.1 ,ESR , I have SWCV SNC 5.1 and the contents are used in different Interfaces. What all needs to be done in PI during /after the upgrade ( we are unable to see the SNC repository objects in the SPROXY of SNC System after the upgrade)

Thanks & Regards,

VishnuV

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    May 10, 2011 at 08:54 PM

    Hi Praveen,

    Yes , all these are taken care already and we are able to see the other objects in SNC SPROXY except the SWCV SNC 5.1 . What may be the issue. Also , any one help me reagrding the changes that are necessary in PI 7.1 when SNC is upgraded from 5.1 to 7.0?

    Regards,

    Vishnu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Monika & Praveen,

      Thanx for the solution . The latest version import from service market palce solved the problem.

      Regards,

      VishnuV

  • May 10, 2011 at 06:01 AM

    > we are unable to see the SNC repository objects in the SPROXY of SNC System after the upgrade

    Make sure that all proxy framework setting are correct. This has to be done by BASIS team guided by Dev team.

    check the following things in the proxy application system

    Integration Configuration to be done in Target system

    1) Create RFC Destination (Type H) to the PIQ system

    2) Integration Server Configuration

    tcode: SXMB_ADM

    Choose Integration Engine Configuration

    Choose Edit --> Change Global Configuration Data

    Select "Application System" as the role of the Business System

    In Corresponding Integration Server field enter the above RFC destination

    3) Activate the SICF services

    - adapter plain

    - cache_gui

    - cache_ssl

    - docu_apperror

    - docu_syserror

    - engine

    4) Register the Queues

    u2022 Go To transaction sxmb_adm

    u2022 Choose Manage Queues

    u2022 Check the Queues listed there. Select All and click Register. And then

    Activate

    5) Configure SLD Connection Info

    Go To transaction SLDAPICUST

    Enter the XI host name and Java port

    Maintain the userid PIAPPLUSER

    6) Create RFC Destination LCRSAPRFC

    Connection Type: T

    Program ID: LCRSAPRFC_<SID>

    Gateway Host:XI hostname

    Gateway Service: sapgw00 (In general, sapgw<SAPSystemNumber>)

    7) Create RFC Destintion SAPSLDAPI

    Connection Type: T

    Program ID: SAPSLDAPI_<SID>

    Gateway Host: XI host name

    Gateway Service: sapgw00 (In general, sapgw<SAPSystemNumber>)

    8) Verify SLD configurations

    Execute Transaction SLDCHECK

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 11, 2011 at 09:15 AM

    Hi Vishnu

    the content that would be present in PI would be that of 5.1. Please import content for 7.1 in PI and then it should be visible in sproxy.

    Regards

    Monika

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear Vishnu

      Look for the relevant SWCV on service market place for your version. Remeber the content version should match taht of SNC.

      Next log in to ESR and Go to tools -> Import objects and import the tpz downloaded in firts step.

      Sometimes this swcv is not viisble in ESR, in this case check whether PI SLD content is also updated to incorporate new version of SNC.

      Regards

      Monika