Skip to Content
avatar image
Former Member

SAP WEB Dispatcher error

I install the SAP Web dispatcher.

The install log says that everything is ok but I can not log on the web dispatcher via url.

I checked the dev_webdisp and I found the following error:

      • ERROR => ShmCreate: Invalid size. Key=63 Size=15080 [shmux_mt.c 1429]

      [Thr 01] *** ERROR => IcmShmCreate: ShmCreate(63, 15080) failed 2 [icxxshm_mt.c 254]

      [Thr 01] WARNING: MPI Pipe 29 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 28 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 27 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 26 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 25 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 24 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 23 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 22 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 21 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 20 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 19 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 18 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 17 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 16 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 15 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 14 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 13 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 12 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 11 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 10 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 9 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 8 still in use 0 0 1 1

      [Thr 01] WARNING: MPI Pipe 7 still in use 0 0 1 1

      [Thr 01] IcrCoreInitSessionTable: Session table initialized

      [Thr 01] MtxInit: -2 0 0

      [Thr 01] IcrCoreInit: SAP Web Dispatcher server process started

      [Thr 515] *** ERROR => NiPBind: bind failed (socket=8) (13: Permission denied) [niuxi_mt.c 1432]

      [Thr 515] *** ERROR => NiIBind: service '80' (80) in use [nixxi_r_mt.c 3911]

      [Thr 515] *** ERROR => NiIListen: NiBind (rc=-4) [nixxi_r_mt.c 800]

      [Thr 515] *** ERROR => IcmBindService: You might not have the permissions to bind the service: <hostname>com:80 [icxxserv_mt. 1544]

      [Thr 515] *** ERROR => IcmBindService: NiBuf2Listen failed for host <http:<hostname:80>

      [Thr 01] IcmCreateWorkerThreads: created worker thread 0

      [Thr 01] IcmCreateWorkerThreads: created worker thread 1

      [Thr 01] IcmCreateWorkerThreads: created worker thread 2

      [Thr 01] IcmCreateWorkerThreads: created worker thread 3

      [Thr 01] IcmCreateWorkerThreads: created worker thread 4

      [Thr 01] IcmCreateWorkerThreads: created worker thread 5

      [Thr 01] IcmCreateWorkerThreads: created worker thread 6

      [Thr 01] IcmCreateWorkerThreads: created worker thread 7

      [Thr 01] IcmCreateWorkerThreads: created worker thread 8

      [Thr 01] IcmCreateWorkerThreads: created worker thread 9

      [Thr 1029] *** ERROR => IcmConnClientRqCreate: No service for protocol HTTP started [icxxconn_mt. 2503]

      [Thr 1029] *** ERROR => IcmConnClientRqCreate() failed (rc=-1) [icrxx_mt.c 4566]

      [Thr 1029] *** ERROR => IcrIHandleHTTPClientRequest() failed -1 [icrxx_mt.c 2166]

      [Thr 3599] IcmWatchDogThread: watchdog started

      Any idea about the error?

      Add comment
      10|10000 characters needed characters exceeded

      • Follow
      • Get RSS Feed

      1 Answer

      • Best Answer
        avatar image
        Former Member
        May 09, 2011 at 07:17 PM

        Perform this and restart the Web Disp:

        First stop or kill the webdispatcher process and then

        1. sapwebdisp pf=.... -cleanup

        2. sapwebdisp pf= < location of profile> -shm_attach_mode 6 & (IN THIS CASE FIRST CHECK THE PROFILE IF shm_attach_mode = 6 THEN YOU DON'T HAVE TO USE THIS, INSTEAD USE THE 3RD COMMAND)

        3. sapwebdisp pf=<LOCATION> & (IF THIS IS WINDOWS CREATE A SERVICE)

        Regards

        SM

        Add comment
        10|10000 characters needed characters exceeded

        • Former Member Former Member

          I was looking for something else, stumbled upon this. Someone looking for a clue, this is due to the fact that a user without root priviliges (eg <sid>adm) does not have permissions to bind ports below 1024. U should use the paramater EXTBIND=1, which is explained in note 421359

          Restarting teh WebDispatcher is done from the administration window (<wbdispatcher url>/sap/wdisp/admin)

          Edited by: M. Loohuizen on Oct 26, 2011 2:57 PM