Skip to Content
author's profile photo Former Member
Former Member

Issue with PI picking messages from Websphere MQ

Hi All,

We have an issue with our interfaces in SAP PI (version 7.0, SP 19) which connect to Websphere MQ (version 5.3) using JMS adapter (having deployed JMS drivers version 5.3) to pick messages from its queues. We have only One Queue Manager(other connections with this Queue manager have no issues reported) and 4 queues from which our 4 PI interfaces pick messages from . These interfaces were running fine from past six months and suddenly it was observed that the Messages greater than 10KB are not being picked up from MQ. Messages with Size upto 5KB are received by SAP PI. Messages with size 7 KB are coming into PI with much delay (nearly 1-2 hrs) . No changes have been done at MQ and at PI configurations from past six months. Earlier we used to pick messages of size upto 4 MB from the MQ with no issues.

The only change could be the Kernel Upgrade in PI at that time before the issue just came up.

Observed Behaviour at PI :

Communication Channel shows no error logs. All Channels have status as successfully connected to Queues. Found server logs : u201Ccom.ibm.mq.MQException: MQJE001: Completion Code 2, Reason 2019u201D.

Observed Behaviour at MQ :

Messages from MQ disappear ( looks like being picked up) and queues have uncommitted status however after few minutes the messages appear again on the original queues, status changes back to committed.

We have done every check like :

Stopped the PI Channels and started, deleted queues on MQ and recreated, Restarted PI instance. u2013 No results.

We have applied the SAP note : 1086303 which talks about parameter with name 'activateExceptionListener'. But no results.

The MQException: MQJE001: Completion Code 2, Reason 2019 u2013 guides to IBM TechNote : http://www-01.ibm.com/support/docview.wss?uid=swg21229508. This was not implemented in MQ server as there was no such settings available on the server. ( We donu2019t have WAS for MQ).

Even the network team has confirmed its not a issue with Network/Firewall. (There are 2 Firewalls between PI and MQ servers. There was no change on the Firewall Rule as confirmed by the Network Team).

Please suggest if you have faced this kind of issue. We are facing this issue in Production environment. Hence any response will be much help.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on May 09, 2011 at 06:34 PM

    PI optimum message size handlling is upto 5 mb. More than 5 MB could cause performance issues. We had this issue..

    a) Increase the tuning parameter in SXMB_ADM as follows

    Category: TUNING

    Parameter: EO_MSG_SIZE_LIMIT

    Current value: 20480 (or some require value)

    default value:0

    b) Scheduled this message interface in the off peak time likei n the early morning

    The above things might help for some extent.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Prasanna ,

      have you checked on the SAP server on which queue is installed .are you getting any error log there .Just view the trace file of communication channel you might get some error log which will give you more insight in the issue .

      Regards,

      Saurabh

  • Posted on May 10, 2011 at 11:35 PM

    Hi Prasanna,

    Since you have done all the initial check and workarounds. I will suggest you to raise a OSS message as this looks like some standard issue with the kernel path. Let SAP have a look at the issue and provide you with a solution

    Regards

    Suraj

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 14, 2011 at 03:10 PM

    Thanks for all your replies.

    The issue got resolved due to change in Network configuration. The issue was nothing to do with PI configuration. It was a problem in Network Switch between the PI and MQ server. When the Switch mode was changed to Full Duplex, the messages started getting picked up from MQ. Apologies for the late post.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.