Skip to Content
author's profile photo Former Member
Former Member

No active userstore is set

Hi

I receive this error from ther server0 when installing webas for java on windows.

Loading: LogManager ... 2703 ms.

Loading: PoolManager ... 266 ms.

Loading: ApplicationThreadManager ... 844 ms.

Loading: ThreadManager ... 406 ms.

Loading: IpVerificationManager ... 0 ms.

Loading: ClassLoaderManager ... 94 ms.

Loading: ClusterManager ... My Library Path is: C:\j2sdk1.4.2_06\jre\bin\server;C:\j2sdk1.4.2_06\jre\bin;C:\j2sdk1.4.2_06\bin;D:\usr\sap\J2E\JC00\j2ee\os_libs;D:\ORACLE\EP6\920\jre\1.4.2\bin\client;D:\ORACLE\EP6\920\jre\1.4.2\bin;D:\TREX\Python\.;C:\jdk1.3.1_11\bin;D:\ORACLE\EP6\920\bin;C:\Program\Oracle\jre\1.3.1\bin;C:\Program\Oracle\jre\1.1.8\bin;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program\Microsoft SQL Server\80\Tools\BINN;D:\TREX;D:\usr\sap\J2E\SCS01\exe;D:\usr\sap\J2E\JC00\exe;D:\usr\sap\J2E\SYS\exe\run

2234 ms.

Loading: LockingManager ... My Library Path is: C:\j2sdk1.4.2_06\jre\bin\server;C:\j2sdk1.4.2_06\jre\bin;C:\j2sdk1.4.2_06\bin;D:\usr\sap\J2E\JC00\j2ee\os_libs;D:\ORACLE\EP6\920\jre\1.4.2\bin\client;D:\ORACLE\EP6\920\jre\1.4.2\bin;D:\TREX\Python\.;C:\jdk1.3.1_11\bin;D:\ORACLE\EP6\920\bin;C:\Program\Oracle\jre\1.3.1\bin;C:\Program\Oracle\jre\1.1.8\bin;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program\Microsoft SQL Server\80\Tools\BINN;D:\TREX;D:\usr\sap\J2E\SCS01\exe;D:\usr\sap\J2E\JC00\exe;D:\usr\sap\J2E\SYS\exe\run

1672 ms.

Loading: ConfigurationManager ... 7563 ms.

Loading: LicensingManager ... 203 ms.

Loading: ServiceManager ...

Loading services:

service memory started. (31 ms)

service jmx_notification started. (32 ms)

service cross started. (15 ms)

service file started. (172 ms)

service runtimeinfo started. (0 ms)

service timeout started. (438 ms)

service p4 started. (1016 ms)

service userstore started. (515 ms)

service classpath_resolver started. (0 ms)

service deploy started. (2063 ms)

service tcsecwssec~service started. (2953 ms)

service log_configurator started. (5984 ms)

service locking started. (0 ms)

service failover started. (6094 ms)

service naming started. (1047 ms)

service http started. (1203 ms)

service javamail started. (1203 ms)

service appclient started. (1188 ms)

service ts started. (1250 ms)

service jmsconnector started. (1297 ms)

service connector started. (1500 ms)

service webservices started. (1453 ms)

service configuration started. (172 ms)

service licensing started. (593 ms)

service dbpool started. (4406 ms)

service com.sap.security.core.ume.service started. (2860 ms)

service security ================= ERROR =================

CORE SERVICE ERROR! security

com.sap.engine.services.security.exceptions.SecurityServiceException: Unexpected exception:

at com.sap.engine.services.security.SecurityServerFrame.start(SecurityServerFrame.java:162)

at com.sap.engine.core.service630.container.ServiceRunner.startApplicationServiceFrame(ServiceRunner.java:144)

at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceRunner.java:107)

at java.lang.Thread.run(Thread.java:534)

Caused by: com.sap.engine.services.security.exceptions.BaseSecurityException: No active userstore is set.

at com.sap.engine.services.security.server.UserStoreFactoryImpl.getActiveUserStore(UserStoreFactoryImpl.java:77)

at com.sap.engine.services.security.server.jaas.LogonInfoLogger.update(LogonInfoLogger.java:279)

at com.sap.engine.services.security.server.jaas.LogonInfoLogger.<init>(LogonInfoLogger.java:50)

at com.sap.engine.services.security.server.SecurityContextImpl.<init>(SecurityContextImpl.java:54)

at com.sap.engine.services.security.SecurityServerFrame.start(SecurityServerFrame.java:125)

... 3 more

-


caused by -


com.sap.engine.services.security.exceptions.BaseSecurityException: No active userstore is set.

at com.sap.engine.services.security.server.UserStoreFactoryImpl.getActiveUserStore(UserStoreFactoryImpl.java:77)

at com.sap.engine.services.security.server.jaas.LogonInfoLogger.update(LogonInfoLogger.java:279)

at com.sap.engine.services.security.server.jaas.LogonInfoLogger.<init>(LogonInfoLogger.java:50)

at com.sap.engine.services.security.server.SecurityContextImpl.<init>(SecurityContextImpl.java:54)

at com.sap.engine.services.security.SecurityServerFrame.start(SecurityServerFrame.java:125)

at com.sap.engine.core.service630.container.ServiceRunner.startApplicationServiceFrame(ServiceRunner.java:144)

at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceRunner.java:107)

at java.lang.Thread.run(Thread.java:534)

Anyone else got this? Ideas?

Cheers,

Max

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 29, 2004 at 02:08 PM

    Hi -

    I am getting this same error. Did you get a resolution?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 27, 2005 at 04:15 PM

    Hi all,

    Did you search the http://service.sap.com/notes for a solution?

    If you can't find a solution then maybe creating a support message on the http://service.sap.com/message

    Best regards,

    Hay

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 18, 2011 at 02:48 PM

    Dear Max,

    There is a note that deals with the exact case:

    SAP Note No. 1042418- "No active userstore is set".

    When the UME is connected to ABAP server, below are the parameters that need to be checked. Steps :

    1) Login to the configtool->switch to the configuration editor mode->configuration->cluster_data->server-> cfg> services->

    Propertysheet com.sap.security.core.ume.service.

    Check the below values:

    ->ume.persistence.data_source_configuration= dataSourceConfiguration_abap.xml

    ->ume.login.guest_user.uniqueids : J2EE_GUEST

    ->ume.r3.connection.master.client :< Backend client to which the j2ee has to be connected >

    ->ume.r3.connection.master.msghost

    ->ume.r3.connection.master.r3name :

    ->ume.r3.connection.master.user :SAPJSF (SAP_BC_JSF_COMMUNICATION should be assigned in the backend)

    ->ume.r3.connection.master.passwd: <passwd of the sapjsf user>

    Make sure that the J2EE_guest user is present only in the ABAP server (not in the local DB) and has the role SAP_J2EE_GUEST assigned to it.

    After that restart the J2EE engine. For more info:

    http://help.sap.com/saphelp_nw04/helpdata/en/84/10594aecd3e1408845e66c43

    2b955e/frameset.htm

    If the issue persists, trigger a restart of the engine anc check the below logs:

    /usr/sap/<SID>/JC<nr>/cluster/server0/logs/defalt trace.trc and the work folder updated files. This should help in future investigation.

    Please close the thread if the query is resolved.

    Thank you and have a nice day!

    _____________

    Kind Regards,

    Hemanth

    SAP ACTIVE GLOBAL SUPPORT

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.