Skip to Content
avatar image
Former Member

Webdynpros coming up Blank

I'm having an issue with all of our Webdynpro applications in Solution Manager. Our maintenance optimizer, Self-diagnosis and DVM transactions have all stopped working for some reason. Each of these transaction were working a few weeks ago just fine but they just all of a sudden just stopped. All the applications keep coming up with a blank screen with a java script error saying: 'wdaOnMainLoad' is undefined and Expected ';' wda_IS_main.js. There are no errors in ST22 or any other indication that there is an issue. I've searched high and low but cannot find a solution on this.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 07, 2011 at 08:01 AM
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Connie Baldon,

      I am also facing the same issue. please can you let me know on which basis release & ST release is your SolMan ?

  • May 06, 2011 at 11:50 PM

    Hello Connie,

    Try the following:

    -


    (1)

    Please activate all required services based on SAP Note

    #1088717 Active services for Web Dynpro ABAP in transaction SICF.

    I hope activating all required services will solve your issue.

    -


    (2)

    In Tr. SICF the service

    /default_host/sap/public/bc/webdynpro/ssr

    Public services should not have a user assigned in Tr. SICF. If a user is assigned, remove it.

    -


    (3)

    Please, apply these notes below

    1417118 Triggering exit plug or suspend plug causes JavaScript error

    1435260 Parameter transferred incorrectly with exit plug

    And update note 1405878 yo the latest version. Don't forget to perform

    the manual steps of note 1405878.

    After follow these steps reply the results.

    -


    (4)

    Implement this note 1417118

    -


    I'm sure that the 4 recommendations will solve your issue.

    For your guidance, the right component for this is BC-WD-ABA, if you wish to trigger a OSS message.

    Best regards,

    Guilherme Balbinot

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi there! I've gone through all the notes you've suggested and deactivated then reactivated all the services in SICF but it is still not working. I've tried looking through the other forum posts but those answers still have not fixed the issue. I'm also not able to run any transactions like solman_setup since the java keeps getting an error so some of the notes that require post activities are not able to run in the system.