Skip to Content

BEX Query Changes are not Reflecting in WAD

Hello SDN Experts,

I'm Facing a Typical Weird Issue. We got an Requirement to Create a New Variable in a Exisitng BEX Query. Assume that we have already a Variable on 0VENDOR. So I have Removed that Variabale and Added new Variable which was created by myself. So when I execute the Query I;m gettign displayed the new Variable wihch is working fine.

But the problem is with WAD. WAD is showing both the old and new Variables. So in selection paramater it is displaying two 0VENDOR variables instead of showing one.

Could you please Guide me how can the BEX Changes will get reflected in WAD report as well ???

Your advice are highly appreciated

Regards,

Aluri

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on May 05, 2011 at 08:43 PM

    Hello Hemanth,

    This issue may be because you only removed variable but didn't change the 'input ready' settings of it.

    Steps, go back to removed variable -- properties --- details -- then deselect 'variable is ready for input' -- save and exit -- try WAD report..

    Hope this will help.

    Thanks.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 06, 2011 at 07:02 AM

    hi,

    Try this

    In RSRCACHE in Main memory expand Query Directory and try to delete Cache objects for particular query

    Regards,

    Ray

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 06, 2011 at 09:00 AM

    Hi Hemant,

    I am not sure if u created input ready variable directly in WAD and did not remove it later.

    If it is not a big deal, just create a new WAD and insert the new query...

    REgards,

    Vikram

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.