Skip to Content
avatar image
Former Member

Stubborn error in efiling gb config

Hello guys,

I am getting a very stubborn error in efiling(gb) config in PI 7.1.

Firstly here is a trace on the error.

<Trace level="1" type="T">Runtime Exception when executing application mapping program com/sap/xi/tf/_HR_GB_EFO_EOYR_OUT_; Details: com.sap.aii.utilxi.misc.api.BaseRuntimeException; RuntimeException in Message-Mapping transformation: Cannot produce target element /ns0:GovTalkMessage/ns0:Body/ns1:IRenvelope. Queue does not have enough values in context. Target XSD requires a value for this element, but target-field mapping does not produce one. XML instance is probably not valid for source XSD, or target-field mapping does not fulfil requirements of target XSD.

Now here is what I have already tried and checked,

1. E-Filing content fully updated (patch 19)

2. SAP HR 6.00 (68) and SAP HR 6.04 (34) content.

3. Payload tested in IR passes OK on the message mapping HR_GB_EFO_EOYR_OUT.

4. Payload tested in ID fails with error above on interface determination (operation mapping).

5. Namespace on configuration has been double checked and is correct.

6. Namespace on XML message is also for the correct year.

What I just do not understand is why the same mapping fails from ID but passes from IR. Any hints?

Regards,

Ahsan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    May 04, 2011 at 09:58 AM

    Further to the information above, I notice that efiling content all refers to SAP HR 6.00 versions content when refering to mapping functions. Since the sender business system is 6.04 and CSV's displayed in it are all coming from the SLD, is it possible that this is confusing the integration engine?

    If so, does this mean that efiling content is not working for 604 for the moment? I would be very surprised if this was the case.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi All,

      Managed to solve to the problem. Unfortunately there was no clever solution. After exhausting every possible avenue of investigation, deleted the complete scenario config. Restarted the server and re-did the config.

      And before you suggest it, I had tried refreshing all buffers and re-did the config once without a restart. Solved but a disappointing end to 3 days of effort. 😊

      Cheers,

      Ahsan