Skip to Content
author's profile photo
Former Member

CR 2010 & VS2010 load problem

Hi All

I've VS2008 Pro. with CR2008 and VS2010 Ultimate with CR2010 in the same box which is Win 7 Ultimate.

I developed an asp.net application using VS2010 and create some reports on CR2010, the reports are working and loading just fine in development (from VS).

But once i deploy it to IIS (in the same machine), the application is working fine but when loading the aspx file that hosting the CR file it gives me an (Load report failed) error.

Find below the full ex.Tostring:

CrystalDecisions.Shared.CrystalReportsException: Load report failed. ---> System.Runtime.InteropServices.COMException: Unsupported Operation. A document processed by the JRC engine cannot be opened in the C++ stack. at CrystalDecisions.ReportAppServer.ClientDoc.ReportClientDocumentClass.Open(Object& DocumentPath, Int32 Options) at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.Open(Object& DocumentPath, Int32 Options) at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened() --- End of inner exception stack trace --- at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened() at CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename, OpenReportMethod openMethod, Int16 parentJob) at CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename) at Reports_rptMsg.Page_Load(Object sender, EventArgs e) in C:\Users\Nabeel\Documents\Visual Studio 2010\WebSites\Portal\rptMsg.aspx.vb:line 16

Any advice,

Thanks in Advance.

Nabeel

Edited by: Nabeel.Hassan on May 1, 2011 10:56 AM

Edited by: Nabeel.Hassan on May 1, 2011 11:10 AM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Posted on May 01, 2011 at 02:44 PM

    Hi Nabeel,

    Are you using SP1 for CR for VS 2010, version 13.0.1.220?

    Is your OS 32 or 64 bit and is the app pool also using the same platform?

    Check your web.config file to verify there are no 10.5 references, if there are then remove them.

    What Framework are you using? Is you App set to use the same?

    What DB driver are you using?

    Thank you

    Don

    Add comment
    10|10000 characters needed characters exceeded