Skip to Content

RNIF Angled brackets in the Content Id in the attachment

Hello All,

I'm working on an RNIF interface with a PIDX message and an attachment . Everything is working fine until this new requirement came up . The partner that we are communicating with needs the content-id of the attachment to be enclosed in angled brackets <>. I know that this issue has been resolved in PI 7.1 EHP1 , but we are on PI 7.0 .

Please let me know if there is a support pack in 7.0 for this and if so which one . Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Posted on May 04, 2011 at 03:53 PM

    Hello

    Check the SAP note #1554216 RNIF Adapter doesn't use angled brackets(<>) for Content-ID.

    Regards

    Mark

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks for your reply . We raised a ticket with SAP and SAP responded with same note number . It talks about setting the Add-Angled-Brackets-To-Content-ID . My question is where would we set this attribute . Is it a module parameter .

  • Posted on May 04, 2011 at 04:42 PM

    Hi

    Yes, this is a module parameter for the RNIFModuleListener module.

    Regards

    Mark

    Add comment
    10|10000 characters needed characters exceeded

    • That note talks about Support packs and patches that supports this attribute . In the listing there is SP12 for AF and AFC . So we were under the impression that this attribute is available on SP12 and above .

      Right now we are on PI 7.0 SP 14 stack and i have set the attribute to 'true' for the RNIFLISTENER module , but the content-id is not coming enclosed in <> . So does that mean that the Add-Angled-Brackets-To-Content-ID is not available in SP14 which is above sp12 .

      Thanks again for your reply .

  • Posted on May 04, 2011 at 05:09 PM

    Hi

    The parameter is not available for SP14. Note #1554216 is a relatively new note. SAP will generally provide fixes for the previous 3 SP releases (e.g. SP24, SP23 and SP22 in this case).

    It looks like this specific fix was provided for a customer on SP12. I guess you will need to request they do the same for your SP14 release (if upgrading is not an option for you).

    Regards

    Mark

    Add comment
    10|10000 characters needed characters exceeded