Skip to Content
0
Former Member
Apr 24, 2011 at 11:20 AM

Objects missing in the database

113 Views

Hello,

I am trying to install a test system using homegenous system copy method from production system .

SAP version is ERP 6.0, Kernel Patch is 275. Using SR3 installation DVDs.

OS verion is iSeries V6R1M0.

Using IASP.

Unfortunately I got an error on Adjust name table step as follows (I did this copy procedure many times before but never got this error)

"CJS-30023 Process call '\usr\sap\URT\SYS\exe\run\dipgntab -rwr40 -srctt DDNTT -srctf DDNTF -dsttt DDNTT -dsttf DDNTF -ttonly TT' exits with error code 255. For details see log file(s) dipgntab.log."

dipgntab.log is as follow.

/usr/sap/URT/SYS/exe/run/dipgntab=>sapparam(9): environment variable $SAPSYSTEM format error.

ERROR in initialization (can't get R/3-version)

ERROR in initialization (can't get R/3-version)

I log on to the system and ran the command "/usr/sap/URT/SYS/exe/run/dipgntab -rwr40 -srctt DDNTT -srctf DDNTF -dsttt DDNTT -dsttf DDNTF -ttonly TT".

Output is as follows;

-


>> "69604" active nametabs found

>> "69604" active nametabs rewritten

>> "0" rewrites failed

End: Rewrite of active nametabs ("20110423225210")

-


Begin: 2011/04/23 22:39:32, rewrite of Shadow-Nametabs

End: 2011/04/23 22:52:10, rewrite of Shadow-Nametabs

"69604" Shadow-Nametabs rewritten

>> 69604 Nametabs found.

>> 69604 Nametabs rewritten.

>> 0 rewrites failed.

After this I thought that this step is okey and edited keydb.xml and skipped this phase of the installation and finished the installation without any error.

My system is up now and everthing seems normal except the tables and views in DB.

I ran SM28, SE06, SM37, SU01 and no error. No error on SM21 and ST22. Also no error on trace files in work folder.

When I run DB02 it shows me that there are missing objects in DB as follows. All objects are

Object Type Coumt Size(KB) Missing In DB Missing in Dictionary.

Tables 69782 5359755968 69707 0

Primary keys 69771 490744148 0 0

Indexes 13670 314557808 0 0

Views 9845 0

Question is what did I miss by running dipgntab command on OS using SIDADM user and skipping this phase from keydb.xml?

How can I solve the issue? How can I make objects are known by SAP?

Thanks and kind Regards,

Yuksel AKCINAR