on 04-21-2011 2:38 PM
Hello,
When trying to make adjustments to multiple contracts we are receiving the error message 'Document is still being processed in the background; try again later.' We have tried again later to no effect.
Ultimately, this means that these contracts (30 altogether) cannot be altered in anyway i.e. held, deleted, released, approved and it means that they just sit there.
This also has implications when raising another contract to replace these contracts. For example if you want to use the same vendor this will cause great confusion for our users when trying to select the correct correct to spend money against when raising purchase orders. Often the result is the user selecting the wrong contract.
Have you any suggestions on why this error message is appearing?
Many Thanks,
Sarah
The documents can be unlocked even by deleting the workflow that will be usually stuck in held status or in error. Sometimes even deleting the entry in table BBP_WFLOCK doesn't release the document for changes in such a case we may have logically delete the workflow. This allows you to change the order and again re trigger the workflow. It should work fine then.
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Check if anybody is locking the contracts by looking at transaction SM12.
If not, check table BBP_WFLOCK and see if there are any entries pertaining to these contracts. If so, delete them to unlock.
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check it is applicable for you
Note 1454289 - Multiple documents created from SOCO via background job
Symptom
In the Sourcing Cockpit, when follow-on documents are created for requirements via the background job, the Purchaser is able to add the requirements again to the Sourcing Cockpit Work Area and create follow-on documents for the same requirements. This note prevents the Purchaser to create multiple follow-on documents for the same requirement and throws an error message "Document is still being processed in the background; Try again later".
Other terms
BBPSOCO01; BBPSOCO02; BBP_PD; 443; background task; bbp_ct_threshold
Reason and Prerequisites
The reason of the above problem is program error.
Solution
Kindly apply the attached corrections or import the corresponding support package.
1465740 - SRM document is stuck in the approval process
Symptom
Workflow hangs.
Workflow gets stuck.
SRM document in status waiting.
Approval process cannot continue.
SRM document frozen in status 'awaiting approval'.
BBP_PD 443 Document is still being processed in the background; Try again later
BBP_ICON_TEXTS 049 No workflow started. Application error occurred
Environment
SAP Supplier Relationship Management
Reproducing the Issue
Create or change a document in SRM.
Cause
*Not possible to identify root cause without further deeper analysis
Resolution
Find the object guid of your SRM document via transaction BBP_PD.
Then display the relevant workflow instance via transaction SWI6 using the following steps:
Select BOR object type.
Enter your object type.
Enter your guid (or document number in the case of shopping cart) in the Key field.
Select variant All Instances.
Select selection period All.
Hit execute.
Click on icon 'Display workflow log'.
Click on icon 'List with technical details'.
Click on icon 'Print Log'.
Record the date and time of the very last step in the workflow log.
Using the date and time of the last workflow step, here are some transactions that can be used to investigate the root cause of the problem.
SM58 - check for stuck remote function calls
ST22 - check for system dumps
SM13 - check for stuck update requests
SM21 - check in the system log for anything unusual
SWUD - run a consistency check on the workflow
Enter the task number and hit enter e.g. 14000044
Choose 'Test Environment' and flag 'Including parts'
Execute
Choose 'Consistency check for components' and flag 'Including subworkflows'
Execute
Red lights indicate an error in the definition.
Header Data
Released on 05.05.2010 09:53:08
Release status Released to Customer
Component SRM-EBP-WFL Workflow
Priority Normal
Category Problem
.*
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