Skip to Content
author's profile photo Former Member
Former Member

XI 3.0 Outbound File Adapter (FTP) Status Code 401 Unauthorized

I have reviewed other related posts but there are either 2.0 or inbound file specific.

This is broken into 2 parts. Part 1 is the current issue, part 2 is ultimately what I am attempting to do.

1) FTP send

I am attempting a basic scenario of an Idoc being sent to XI, mapped to a simple structure (only 2 fields), and output to a outbound file adapter. The error message I see in SXI_monitor is: HTTP response contains status code 401 with the description Unauthorized XML tag Envelope missing in SOAP message header (SAP XI Extension)

Again this is an outbound file adapter configured to ftp via port 21 to a unix machine. Outside of the typical user / pw authorization issues, what else should I be looking for?

2) SFTP send

THe intention if the above is working is to then make this a SFTP send using port 22. I am assuming this is possible? Any other configs I need to be aware of?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 22, 2004 at 04:37 PM

    Part 1 answered, part 2 still requires resolution.

    Part 1 solution: Some of the required services in SICF transaction had not been activated. Once done, the adapter functioned as expected.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 14, 2004 at 01:34 AM

    All,

    Getting more details from my infrastructure guys, it was not directly related to the SICF services as I was originally told. Rather, they indicated it was an 'authentication' issue within the SICF services. To correct, they used a default user 'SICFUSER' that has the same authorizations as 'XISUPER'. After the services were reactivated and I was able to ftp.

    If this is documented anywhere, it would most likely be in the tech install docs - but I never saw it....

    Good luck

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.