Skip to Content
author's profile photo Former Member
Former Member

Query cannot get refreshed (connection via universe)

Hello experts,

I have a dashboard that retrieves data from a universe (.unx) via a query. The first time I load the dashboard, the data is retrieved and reflected in my pie chart.

In the query settings, I have set the refresh property to: every 6 seconds. So, 6 seconds after displaying the dashboard, it should refresh the data. However, the refresh doesn't work and the data in the pie chart disappears after 6 seconds. Just to test, I have played with the settings so that the data gets refreshed whenever the value of a cell changes; same result. When the value of the cell changes, the re-querying of the data fails.

What could cause this? The initial load is successful but the refreshes after fail.

I have installed flash player debugger but it didn't give me any errors.

Regards,

Guven.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 20, 2011 at 03:46 PM

    Hi Guven,

    Can you rty refreshing the connection manually and record the changes.

    Take a Connection refresh button from Web Connectivity Component list.

    Go to properties .... check the desired Webservice.

    in the preview mode refresh the connection with Connection refresh button.

    Lte me know if this fails.

    2) Check the connection link in browser

    ping server continously from DOS_Prompt while runing your dashboard, check when ever the connection fails wather the server is giving reply or not.

    Are you refreshing only one connection ?

    Regards,

    Anjanikumar C.A.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Jay Thoden van Velzen

      Hello Jay,

      Thanks for the big picture. I have to aplogize that my initial post wasn't clear.

      I have set the refresh rate to "6 seconds" because of testing purposes; I am actually not even going to use the refresh for my dashboard. It was just to isolate the problem and see if there is anything wrong while retrieving the data. I am actually using the drill-down functionality and the data will be retrieved when the user clicks on a slice in the pie chart.

      Regards,

      Guven.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.