Skip to Content
author's profile photo Former Member
Former Member

Problem using select-options?

Hi all,

I am using select-options, in this 3 are selectoptions and 1 is normal.

i am getting select-option value using..

*cust code

rt_KUNNR = wd_this->m_sel_opt->get_range_table_of_sel_field(

i_id = 'KUNNR' ).

but which method i ahve to use to get normal which is not of select-options.

i am doing like this...

*cust code

rt_YEAR = wd_this->m_sel_opt->get_range_table_of_sel_field(

i_id = 'GJAHR'

). // I think this method is wrong place i used.

assign rt_YEAR->* to <fs_GJAHR>.

move <fs_GJAHR> to F_YEAR.

*cust code

rt_KUNNR = wd_this->m_sel_opt->get_range_table_of_sel_field(

i_id = 'KUNNR' ).

assign rt_KUNNR->* to <fs_kunnr>.

clear S_KUNNR.

loop at <fs_kunnr> into S_KUNNR.

wa_kunnr-sign = S_KUNNR-sign.

wa_kunnr-option = S_KUNNR-option.

wa_kunnr-low = S_KUNNR-low.

wa_kunnr-high = S_KUNNR-high.

append wa_kunnr to it_kunnr.

endloop.

But it is giving dump.. Field symbol has not yet been assigned. at kunnr. but kunnar is select-option.

Any helps...

Thanks

venkat.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2011 at 01:35 PM

    Have you checked in debugging, where rt_kunnr table is filled or not...

    I guess the range table is NULL..please check this out

    in the ADD_SELECTION_FIELD what is the ID that you have given.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.