Skip to Content

Activation of Activity failed. Error adding Message Area in View

Hi,

I got the following error while activating activity from NWDI. (WDJ)

UIElement MessageArea [Pattern]: UIElementLibrary is not used in this Component (Hint: Add UIElementLibrary)

The component is localy getting build successfully. but throwing error while activating the activity.

I checked "Edit UI Element Library Reference". and the "Pattern" library is selected.

Please help me if i need to check any other properties.

Thanks,

Chinmaya

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Apr 19, 2011 at 06:59 AM

    Hi Chinmaya,

    In NWDS, right-click on your Web Dynpro component.

    From the context menu, select 'Edit UI Element Library Reference

    In the popup window, check 'Pattern', then build and deploy/activate

    Best regards,

    Robin van het Hof

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 19, 2011 at 05:28 PM

    Thanks Robin.

    Somehow due to NWDI code conflict the UI Library reference is not getting updated in .wdcomponent file even after editing this in Edit UI Element Library Reference.

    Solved

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.