Skip to Content
0
Apr 18, 2011 at 06:54 AM

PI711: JNLP call is using HTTP instead of HTTPS when using reverse-proxy

350 Views

Hello,

we are running the PI 7.11 in the internal network while the developers are outside of the network.

Scenario:

- SAPGUI is routed via saprouter and working fine.

SAPGUI -> SAPROUTER -> ABAP

- WebAccess (HTTPS) is done via a reverse proxy that is forwarding every request internally to the HTTP-Port of the PI-system

(we are not using HTTPS for the SAP-system internally)

Browser(Client) -> HTTPs -> ReverseProxy(F5) -> HTTP -> ABAP (BSP/WebDynpro)

We added the "clientprotocol=https" parameter in the ReverseProxy to force ABAP-Stack to generate HTTPS-URLs instead of just answering the HTTP-call from the reverse-proxy with HTTP-URLs again.

We maintained the HTTPURLLOC table to get the correct FQDN in the URL.

Thatu2019s working fine.

Problem:

We are calling the IntegrationBuilder via URL https://<fqdn>:<https-port>/dir /start/directory.jnlp

but the first JavaWebStart-Screen shows that the HTTP (not HTTPS) is used inside the JNLP-file for all further steps.

Does anyone know how the jnlp-generation is working and how to force the system to use HTTPS instead of HTTP.

(By the way it would be good to know if anyone out there is running a scenario with PI-developers outside a firewall and routing everything PI-related over reverse-proxies and firewalls.

Till now I had all the developers connected via VPN and close to the server)

Best regards

Christian