Skip to Content
author's profile photo
Former Member

401 Error Bringing up Dashboard

Hi All,

We upgraded to 8.81 last night. no problem. Trying to get the cockpit dashboard working.

1. Chosen sales dashboard.

2. Asks for login

3. after 3 attempts get 401- Unauthorized.

I have checked all of this and several times tested connections which have no problem as well as resetting passwords and ensuring license allocation is correct. can't work out what it is,

Launching Cockpit

2.1 Error HTTP 401 Unauthenticated

First test the B1DI and JDBC connection from the SDL

 Root cause 1: Incorrect B1i password (-107 - Wrong B1i password)

 Solution 1: The B1i password must be set up and changed in SAP Business One. In case of

doubt you should reset the B1i password and test again.

 Root cause 2: Incorrect company selected/company not upgraded (-103 - Failed to connect)

 Solution 2: Ensure in the company field the correct database is used. Also ensure the

database has been upgraded to the correct patch.

 Root cause 3: License has not been assigned (100000013 - Wrong B1i license)

 Solution 3: Ensure the licenses B1iINDRIECT_MSS and B1i have been assigned to the B1i

user.

 Root cause 4: JCO not installed or path incorrect(e.g. Java.lang.NullPointerException)

 Solution 4: When installing the DI API ensures you select the JCO component for installation u2013

you can click on the Custom installation to do this. Also ensure the JcoPath is correctly set in

the SLD (e.g. JcoPath= C:\Program Files\SAP\SAP Business One DI API\JCO\LIB)

 Root cause 5: Incorrect SAP Business One Version

 Solution 5: Ensure you are not trying to connect to the Cockpit/Dashboard when running SAP

Business One 2007 or lowe

 Root cause 6: User selected an old JCO folder during installation

 Solution 6: Change DIProxy properties files to point to correct JCO path and restart DI Proxy

services. To do this open the file (default location is C:\Program Files\SAP\SAP Business One

Integration\DIProxy\diproxyserver.properties) and update the field JCOPATH

2.2 Error 401 not authorized

 Root cause 1: B1i user is not a super user

 Solution 1: Ensure in SAP Business One the B1i user is set as a super user

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • author's profile photo
    Former Member
    Posted on Apr 21, 2011 at 08:58 AM

    Update: I realise the username and password it was asking for was

    You will receive the prompt u201CThe server xxxx at B1iP_ipo_/vP.001sap0004.in_HCSX/com.sap.b1i.vplatform.runtime/INB_HT_CALL_SYNC_XPT.ipo/proc requires a username and passwordu201D

    • Solution:

    UserName: Language/user_name/company_name (e.g. en-US/manager/SBODemoUS)

    Password: The SAP Business One user password (e.g. manager password)

    (language enumeration: cs-CZ, da-DK, de-DE, el-GR, en-CY, en-GB, en-US, en-SG, es-AR, es-CO, es-ES, es-PA, fi-FI, fr-FR, he-IL, hu-HU, it-IT, ja-JP, ko-KR, nl-NL, no-NO, pl-PL, pt-BR, pt-PT, ru-RU, sk-SK, sr-YU, sv-SE, xx-XX, zh-CN, zh-TW)

    although like this thread : Error 401 - Unathorized after requesting username and password

    my entry of en-GB/manager/company and password are not working.

    I have tried reinstalling several times and still no luck.

    am on 8.81 pl04 and I have ensured the usernames/passwords are def correct as well as the correct language.

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on May 03, 2011 at 02:50 PM

    reinstalled event manager

    Add comment
    10|10000 characters needed characters exceeded