Skip to Content
author's profile photo Former Member
Former Member

How to change the default URL of the Webdynpro CTS_BROWSER ?

Hi Experts

I am configuring the CTS+ in our landscape. When I was checking on the cts_browser it's pointing to a different url.

HTTP://xxx.xxx.xxx:60000/sap/bc/webdynpro/sap/cts_browseru201D but it should point to http://xxx.xxx.xxx::8001/sap/bc/webdynpro/sap/cts_browser

I have searched in SE80, but I couldn't able to change the url there.

Could you please help me to resolve the issue.

Thanks & Regards

Venkat

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Posted on Apr 15, 2011 at 10:28 AM

    Hello there,

    You may check in transaction SICF, if you enter service path /sap/bc/webdynpro/sap/cts_browser I think you should be able to change the URL.

    Best regards,

    Miguel AriƱ

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 15, 2011 at 10:57 AM

    Hi

    In the sicf service (cts_browser) there is no place to specify the URL.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      sorry about that, I checked and you are right.

      What do other ICF services do? you could try testing /sap/bc/webdynpro/sap/wda_mopz_plan , for example.

      It could be that a general setting for the whole ICM is not set to your requirements, or it could be that the program that calls the webdynpro is redirecting to the wrong virtual host.

      The different settings about the URL generation can be seen at transaction SMICM, go to-> parameters -> view, but this is for system-wide settings, not for a single service.

      As for the way the service is called, if testing it from SICF still leads you to the 'wrong' URL, there might be a system setting to change, not just the URL for one service.

      Best regards,

      Miguel AriƱ

  • Posted on Apr 19, 2011 at 12:59 AM

    Hello,

    What is the port for your WEB AS ?

    'Protocol'://'server':'Web AS Port'/sap/bc/webdynpro/sap/cts_browser?SYSID='SID of Development System as Configured in TMS'

    It thinks its is on port 60000, you are saying it is on 8001

    What is your icm/server_port_0 parmeter set to for PORT, 80$$ ?

    Pretty sure this is where it gets the port, since it is getting the server from icm/host_name_full

    Mine is set to 80$$

    My URL comes up HTTP://xxx.xxx.xxx:8000/sap/bc/webdynpro/sap/cts_browser

    Check the parameter setting in RZ10, extended maintenance, instance profile.

    Regards,

    Paul

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 20, 2011 at 05:49 AM

    Hi

    I have checked the parameters and I found the values are correct.

    In client 000 the url is correct but in client 500 the url is wrong.

    Thanks & Regards

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 20, 2011 at 06:43 AM
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.