Skip to Content
author's profile photo Former Member
Former Member

SE30 Runtime Errors: CREATE_DATA_ILLEGAL_LENGTH

Dear all, When I am executing a TCode SE30, Runtime Errors CREATE_DATA_ILLEGAL_LENGTH Except occurs. I make sure that my account is correct, I can use this Tcode with my account on others computer . Please give me some solution , Thanks. Best Regards, Eric.

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Apr 15, 2011 at 08:42 AM

    Post the Error where it is showing some arrow mark..

    Check it once.

    Generally this kinds of errors will come when you have Pass value more than Length defiend.

    or else use Data base adjustments to fix first if you make any changes to table after creating data

    Regards

    sas

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Runtime Errors CREATE_DATA_ILLEGAL_LENGTH

      Exception CX_SY_CREATE_DATA_ERROR

      Date and Time 15.04.2011 05:35:53

      Short text

      CREATE DATA: Illegal value for the length of an object of the type "X"

      What happened?

      Error in the ABAP Application Program

      The current ABAP program "CL_ABAP_TRACE_FILE============CP" had to be

      terminated because it has

      come across a statement that unfortunately cannot be executed.

      What can you do?

      Note down which actions and inputs caused the error.

      To process the problem further, contact you SAP system

      administrator.

      Using Transaction ST22 for ABAP Dump Analysis, you can look

      at and manage termination messages, and you can also

      keep them for a long time.

      Error analysis

      An exception occurred that is explained in detail below.

      The exception, which is assigned to class 'CX_SY_CREATE_DATA_ERROR', was not

      caught in

      procedure "READ_INFO" "(METHOD)", nor was it propagated by a RAISING clause.

      Since the caller of the procedure could not have anticipated that the

      exception would occur, the current program is terminated.

      The reason for the exception is:

      A data object of the type "X" with length 0 was to be created using

      CREATE DATA. The value 0 is not within the allowed range.

      Allowed range for the length specification:

      Typ C, N, X: 1 .. 65535

      TYP P: 1 .. 16

  • Posted on Apr 15, 2011 at 09:24 AM

    Hi Eric,

    I'd really like to know how it's possible that the solution is not solved by a SAP note, as suggested by Thomas ? Of course, saslove explained the technical background, but it's not the solution.

    Please think to people who look at whom you credited the solution, they would be very surprised.

    Could you tell us how you solved?

    Thanks

    BR

    Sandra

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Sandra Rossi

      Hello Sandra , The problem has been fixed , thanks. Solution: Step1:SE24 , find class CL_ABAP_TRACE_FILE , and then break point at Method READ_INFO line 31: read dataset FNAME into L_BUFFER_LN. create data L_BUFFER type X length L_BUFFER_LN. Breat point here. Step2:SE30 ,when the break point reached , then change L_BUFFER_LN to an number which bigger than '0', then you will access to the SE30 initial screen successfully . then exit. Check the Application file via 'AL11', you will find the DIR_ATRA--->AT000001 has been delete and replace by another new version one. Then you can execute SE30 successfully. Reason:Please check the Note 896886 , Seems that replace the old version performance file is a better way. Best Regards, Eric.

  • Posted on Apr 15, 2011 at 08:54 AM

    Did you check for SAP notes related to this error?

    Thomas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 18, 2011 at 05:20 AM

    Becasue some wrong operation , i marked the question as answered.So i want recover the status to Not answer , thanks .

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2011 at 03:18 AM

    Problem has been fixed , Thanks for yours attention . For the solution , if anyone are not very clear , you can concate me .

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Eric,

      thank you for the feedback.

      I use one of my colleagues's PC log in the platform under my acount, then execute SE30 MENU-->DELETE FILE .But there is no any performance file found , I think if there are some different version performance file in application server, may be i can't use SE30 with other's too.

      No, you must not select menu -> delete file, you must select menu -> files -> Other files, select user *, and select all dates, that will display all existing files, and then you can delete. As far as I know, there's no authority check (except at the OS level of course). Be careful, the runtime analysis is application-server-dependent, so you may have to switch to another application server (SM51, select another one, double-click, and enter /NSE30 in the command field).

      Anyway, it would have dumped the same way, as any listed file is opened/read by method READ_INFO.

      I am going to re-install my SAP GUI , and try again. I hope it is a way.

      Probably not (as SAPGUI is not related to application server runtime analysis). If the problem happens once again, it will be better to contact SAP support.

      If I have well understood, instead of using debug to be able to delete a trace file, we should interpret this sentence (from note 896886) :

      If this is the case, delete these files.

      as being :

      If this is the case, delete these files from an OS command line, as doing it from SE30 would terminate with a short dump.

      BR

      Sandra

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.