Skip to Content
author's profile photo Former Member
Former Member

Query Stripping not working properly when using variable in the report

We have issue with WEBI document that have query stripping enable.

Once the query stripping enabled there is no data return in the report.

We have investigate on the problem, the query stripping function are notable to retrieve objects that indirectly used in the report

as we have

many variable in the reports.

Ex.

Var1 = object1 + object2

Var2 = Object3 + Object4

Var3 = Var1 + Var2

Var4 = Object1 + Object2 + Object3 + Object4

If we use only Var3 in the report, the object1,2,3,and 4 will not be

retrieve.

But if we are using Var4 in the report, the object1,2,3,and 4 will be

retrieve properly.

Please let me know is it a by-design behavior, if yes please share points on it

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Apr 15, 2011 at 07:56 AM

    is Query Stripping enabled in both query and report level?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.