Skip to Content
author's profile photo Former Member
Former Member

com.sap.portal.appintegrator.sap.WebDynpro::WebDynpro/TopLayer

In my ESS homepage framework I have configured a custom service and resouce for UWL. I can see the ESS overview link but when I click on the service I get a page which displays as follows

MandatoryParameters

====================

com.sap.portal.appintegrator.sap.WebDynpro::WebDynpro/TopLayer

DefinitionType:Java

System:SAP_LocalSystem

Application Name:

Client:Automatic Detection

Optional Parameters

===================

WebDynproNamespace

Application Parameters: Some applications parameters here..

DynamicParameter:sap.xss.menuhdr=SAPDEFAULT&sap.xss.menusrv=ZXXX_UWL&sap.xss.menuargrp=ZXXX_XSS&sap-epcm-guid=5EEB3EB91EF57E57F781D5BE7B20E5E739436F929EBCCE3F60E9A3E0ACBDCBB5&sap.xss.menuarea=ZXXXX__UWL

DebugMode: No

We are running on EP 7.01. The PCD links in the homepage framework are to the page object which contains UWL iView.

All other services are working correctly. There is no log messages in defaultrace. Any thoughts..

Regards

Praveen

Edited by: Praveen11 on Apr 15, 2011 8:57 AM

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Apr 18, 2011 at 03:44 PM
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Siddharth.

      I resolved it by changing the PCD link directly on IMG to a portal page and removed all reference to WD page and WD iview. Your input is useful for resolving the issue.

      Thanks for input.

      Regards

      Praveen

  • Posted on Apr 15, 2011 at 09:24 AM

    Hi,

    does your service expect any parameters on startup? If yes, are they provided?

    The PCD links have to point to the page of the respective ROLE, did you configure it accordingly?

    regards, Lukas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 15, 2011 at 05:37 PM

    clearly URL is incorrect

    you can check via pcd inspector or read note 1086644.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for response. I have check PCD inspector with no errors. Also check the page PCD url on the role is linked to img configuration. I still have the same issue.

      I got 2 PCD pages, one is WD page has WD iView and another is standard portal page with standard UWL iView embedded. when I get the below message as in my first post

      com.sap.portal.appintegrator.sap.WebDynpro::WebDynpro/TopLayer

      on the left navigation panel, I see my 2 pages that are added to a workset as a links. When I click on the page link which has UWL iView embedded it works but I'm expecting it should be automatically be working without showing the above message (refer to my first post).

      Have I missed anything. I even tried to change some setting in IMG to point to iView directly rather than page but still no luck.

      Regards

      Praveen

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.