Skip to Content
author's profile photo Former Member
Former Member

B1ic - B1 8.81 PL01 500 error in Dashboard Widget

Hello all expert,

In the B1 client, I see an error in opening the Dashboard Cockpit. I read all the troubleshoot guide and still cannot find a solution...

Im using 8.81 PL01 and the Integration Component and using company database SBODemoSG.

The B1iC is installed and I have tested the B1DI, JDBC & HAnyforXcelsius connections and both report successful connections.

The error message is like this:

-


SAP B1iP detected an error:

Emitted HTTP-Code

500 - Internal Server Error

Internal Reason

Did not supply an appropriate user-ID integer (Param6):

Recommendation

Check for the correctness of your activity or environment or ask your system-administrator for further help.

tid

110408111437319156860A0102CA8969

Full Internal Error Message

com.sap.b1i.xcellerator.XcelleratorException: XCE001 Nested exception: com.sap.b1i.bizprocessor.BizProcException: BPE001 Nested exeption: java.lang.Exception: Did not supply an appropriate user-ID integer (Param6):

...

-


I already stick on this error for several days.

Would any expert can help to handle this?

Thanks very much!

Regards,

Tim Hung

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Apr 08, 2011 at 12:40 PM

    Hi Tim,

    Have you checked this: b1ic-dashboard-error-500---internal-server-error ?

    Thanks,

    Gordon

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Maria Trinidad MARTINEZ GEA

      Hi there,

      Sorry to thread hijack, but I have just installed 8.81 Pl04 as well as the integration component. I have noticed that a lot of the complicated setup has been removed from 8.81 compared to 8.8. I enabled the widgets in General Settings, restarted all the services in windows services and logged back into SAP. Cannot connect to B1i server - remote server returned a 500 error.

      I have tested the connections to the db and java and all seems to be good.

      Any suggestions? I'm running Windows 7 Professional 32 bit - db is SQL server 2008 SP1

      Thanks

  • author's profile photo Former Member
    Former Member
    Posted on May 17, 2011 at 08:33 AM

    I am having the same problem (I tried on 2 different PC's and the same problem on both of them, the two are running on SBO8.81 PL04).

    Is there already a solution for this problem, because I cannot find it in the documentation you suggested?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Try to log in to 'Integration Framework'. If you are in display SLD and thoroughly check your system. Click both buttons named 'Test...'. If everything looks good then try to check if your scenario and users (Admin and IPO) are in status active. If you still expecting problems then I would suggest to manually remove your system and then re-create it manually. Or just copy from existing and afterwards remove the old one. Of course you should take care of your 'Event Service' setup.

      Hope this helps.

      Best regards,

      Radek

  • author's profile photo Former Member
    Former Member
    Posted on Jun 15, 2011 at 09:49 AM

    hi Tim,

    I have installed SAP B1 8.8 1 PL4 and while accessing the default dashboard 'service call' I am getting the same error as shown below :

    -


    SAP B1iP detected an error:

    Emitted HTTP-Code

    500 - Internal Server Error

    Internal Reason

    Did not supply an appropriate user-ID integer (Param6):

    Recommendation

    Check for the correctness of your activity or environment or ask your system-administrator for further help.

    tid

    110408111437319156860A0102CA8969

    Full Internal Error Message

    com.sap.b1i.xcellerator.XcelleratorException: XCE001 Nested exception: com.sap.b1i.bizprocessor.BizProcException: BPE001 Nested exeption: java.lang.Exception: Did not supply an appropriate user-ID integer (Param6):

    ____________________________________________________________________________________________________

    Have you find any solution for this problem. This is really important.

    Please reply ASAP with a definite solution.

    ________

    Regards

    Sonil

    Edited by: sonilgarg on Jun 15, 2011 11:50 AM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 06, 2011 at 02:55 AM

    Hello all

    I resolved the issue by installing the patch 8.81 PL07

    The dashboard works properly.

    Please have a try!

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 29, 2011 at 03:18 AM

    We have the same problem - SAP 881 on PL 08 with Hotfix1

    SAP message too open - someone from SAP just did a webext with me but stll cant find the issue.

    I am waiting for a reply from them that they promised - will update this thread if I get a useful solution.

    Note: This was a system that was working with dahsboards - bu all of a sudden the DIProxy service refused to start. So we had to reinstall all - and have got all the services starting and connecting, but the dashboards now gives this error.

    what we have is Windows Small Business server 2008 with SQL Server 2008 R2 on a named instance. All on the same local server. We have done all the good work such as making sure the instace name is specified etc etc ....

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2012 at 10:32 AM

    Hi,

    I have successfully installed B1iC but on Dashboard it throws error:

    SAP B1iP detected an error

    Emitted HTTP code

    500 Internal Server Error

    ....

    if you have got through this error do reply,

    need urgently.

    Regards

    Sonil

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.