Skip to Content
avatar image
Former Member

issue with WSDL created for sender agreement

Hi,

Can you please help me why I am getting the erroe with WSDL that has been created from directory Sener agreement in PI 7.1 EHP1?

My interface is a SOAP to file ASYNC scenario and we have been given 5 XSDs that are referencing one each other ,5 XSDs are imported successfully and referenced properly,no errors/issues found.

Created all ESr and directory objects and I tried creating WSDL from sender agreement for my Source/outbound inteface that is created with XSDs in ESR.

When I try to import WSDL into SOPA UI to validate ,the import process stuck for ever while trying to import "http://www.w3.org/2001/xml.xsd" and finally throws me error.

After that I tried importing WSDL created in Directory into AltovaXML spy to created the webservice request,I am getting the following error""invalid XML Schema:"xml:lang" is already declared in the schema dcument C:|..my WSDL.

Even our partner who wants to make Webservice calls using this WSDL,they are not able to develop their Webservices they are getting errors something related to schema not found /not defined etc.

Please let me know,what might be the issue?I verified several times with my XSD imports and referencing properly and configuration objects.

Thank you for your help in advance.

Regards,

Prem

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Apr 08, 2011 at 01:13 AM

    Hello,

    Can you try creating the WSDL in ID using the tools -> display WSDL? Specify your outbound service interface in the wizard.

    Hope this helps,

    Mark

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      My issues has been resolved.Not sure what has resolved the issue.I recreated the Sender agreement for my interface and regenerated the WSDL file and could able to import the WSDL to SOAP UI and can successfully test the interface from SOAP UI.

      There was restart of PI server while I recreated the sender agreement,noy sure,if the restart has helped in refreshing the cache etc.