Skip to Content

How assign Z configuration to WDA standard application

Hi

I need make some changes to standard application Course Registration PIQ_MBSS_OIF wich is FPM application and uses FPM_OIF_COMPONENT.

This application has standard configuration PIQAC_MBSS_OIF so i copied it to Z_PIQAC_MBSS_OIF configuration and i made changes.

My doubt is How can i assign this z configuration to the application ?

I go to SE80 until application and i modify the configuration name parameter WDCONFIGURATIONID, but then appears message TR(852); it lets me modify the parameter but i do not if this is the right way to assign new z configuration to the standard application.

Does somebody can help please.

Best Regards

Frank

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Apr 06, 2011 at 12:47 PM

    You have some suggestion that you need to change the portal iView configuration. That may well be correct, but are you even running this within the Portal? If the application seems stuck with your Z-Configuration, it doesn't seem likely that it is the Portal Configuration that is the problem, since you would have had to change the Portal configuraiton to begin with.

    Test from SE80 and see what happens. This test won't use the Portal iview configuration at all since it isn't running in the portal.

    In general if you are going to create a new configuration (or copy from an SAP one), consider creating a whole new Z-Application. That way there is less confusion as to what configuration ID is used with which Application. Plus you can always easily fall back to running the standard SAP version by running the origianl Application.

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Thomas for advise me do not check por Portal settings.

      I did not changed any value from original configuration but how you says without see my settings is very difficult know what is happening.

      In fact the first time i restore parameter to original configuration it works ok, but then i modified it again to z configuration ; and and return againt to original configuration and then application executes always z configuration (i hope i am explaining).

      So what i had to do is erase Z configuration in order to force application to execute the original conf. because z does not longer exists.

      I'm going to create z configuration again but i wont modify application parameter again , so i will test z conf. directly with right-click/Test.

      Thanks a lot all.

      Best Regards

      Frank

  • avatar image
    Former Member
    Apr 06, 2011 at 08:03 AM

    Hi,

    I think you have done it right. Also I assume that this is transported as enhancement.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 06, 2011 at 08:03 AM

    1. The application configuration can be assigned dynamically by adding the

    query string sap-wd-configID=<appl_config> to the URL used to start the

    Web Dynpro application.

    2. An application configuration can be assigned to the application statically. In

    this case the parameter WDCONFIGURATIONID has to be added to the

    application’s parameter list and the name of the application configuration

    (<appl_config>) has to be defined as the value of this parameter.

    An application configuration assigned to an

    application statically can be replaced by adding the query

    string sap-wd-configID=<appl_config> to the URL (e.g.

    sap-wd-configID=default results in loading the default configuration

    independent of the application parameter settings).

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Aditya

      I did not copied the standard application, i copied the standard configuration.

      So i have the standard application PIQ_MBSS_OIF with two configurations 'PIQAC_MBSS_OIF' and 'Z_PIQAC_MBSS_OIF'.

      The application has in 'Parametrs' Tag the WDCONFIGURATIONID parameter for set the configuration name to execute.

      So first i set this parameter to Z_PIQAC_MBSS_OIF and the application executes this configuration with my changes.

      But then i set the parameter to PIQAC_MBSS_OIF but application remains executing the z configurations with changes.

      I guess this is because last reply saids i must change also the portal administrator iview , but i do not how to do this.

      Thanks & Regards

      Frank

  • avatar image
    Former Member
    Apr 06, 2011 at 11:49 AM

    hi,

    in potal content administrator while creating iview goive configuration id over there.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 04, 2014 at 08:56 AM

    Hey Frank,

    Hope you are doing ok.

    Actually i am trying to do componenet configuration of Personal Profile application.

    Would you please advise me or  help me with some document  , so that i can progress..

    Regards,

    Priti

    Add comment
    10|10000 characters needed characters exceeded