Skip to Content
author's profile photo Former Member
Former Member

Legacy flat file -> XI -> R/3 (IDocs)

Hi Liu,

I was trying to have some hands-on with XI 3.0 demo.

I tried with the following scenario-

Legacy flat file -> XI -> R/3 (IDocs)

e.g., say to create BOM data or material Master.

I take the flat file - create my own External Data Type, message type & message Interface for it in Design(Repository).

And try to map it with the required IDoc Type(msg. type) imported from R/3.

But while mapping, I found certain unknown fields like BEGIN (mandatory), inside the Control Record EDI_DC40- certain fields like SEGMENT, TABNAM, etc.

Al these fields are unknown & I could not figure what to map & how to map them.

Also how do we map Sender port/ receiver- dow e need to hard-code them or we can assign them/map them dynamically.

Would appreciate ur sppedy reply.

Thanks.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Oct 06, 2004 at 12:16 PM

    The EDI_DC40 segment (IDOC header) must not be filled during mapping. The IDOC-adapter fills this segment automatically.

    In the graphical mapping tool do following:

    Move your mouse over the node EDI_DC40, click right button and choose 'Disable Field' from context menu.

    Regards

    Stefan

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Sushil,

      For BEGIN use CONSTANT value 1.

      For Segments, you can use an incrementing value or even a Constant value 1 will work.

      In case of doubt or to check what values your other IDoc fields should hold, manually create an IDoc or look at an existing IDoc.

      Let me know if you still have problems.

      Regards,

      Homiar.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 14, 2004 at 07:39 PM

    I agree with the Segments having and constant value of '1' and also the Begin element = '1', but you may also need to map the constant 'EDI_DC40' to the segment-field EDI_DC40-TABNAM. To do this you will not have to disable the EDI_DC40 segment as recommended in the documentation, but instead map empty values to the required fields in the EDI_DC40 segment i.e SNDPRN, SNDPRT...

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.