Skip to Content
author's profile photo Former Member
Former Member

Need Clearer steps for moving FRS from old active server to new server

Hi Experts,

I am currently planning an upgrade for BusinessObjects XI 3.1 SP2 to SP3 FP 3.4. We had a new VM server built for development to replace the exiting VM Server (30 C drive and 40GB Data drive). We are running Windows 2003 64bit standard with SQL 2008. Once I complete the installs with FP 3.4, I will be moving the FRS from an existing database to a new environment. The part i would like to know in advanced is when I will need to disable/deactivate the current running CMS/SIA? Also, the webserver is running in this environment and i will be installing that on the new server. Basically, I'm looking for the best practice on doing a new install of BOBJ, moving the FRS, and replacing the existing BOBJ. I would like to decomission the existing Dev BOBJ Environment in a few weeks.

Any information or documentation you can provide would be appreciated.

The order in which i will be installing is as follows:

1. BusinessObjects XI 3.1 SP3 FP 3.4

2. Crystal Reports 2008 3.1 SP3 FP 3.4

3. Xcelsius Enterprise 2008 3.1 SP3 FP 3.4

4. SAP Integration kit 3.1 SP3 FP 3.1

5. Live office 3.1 SP3 FP 3.4

6. SAP BusinessObjects Client Tools 3.1 SP3 FP 3.4

7. Life cycle manager 1.0 SP3 FP 3.4

8. Data Federator SP3 FP 3.4

While doing the install in the order above, at which point will i have to turn off the existing CMS or SIA? Is this required prior to the steps where i move the frs to the new database? Below are my steps on how I will move the FRS from the older db to the newer db.

1. Go to the Central Management Console (CMC)

2. Change the file store directory paths in the CMC. These steps need to be executed for each input and output server process

a. Go to Servers  Input

1. InputFileRepository  properties  Change

2. Temporary Directory from old dev file path to new file path
db name\incoming\temp

3. File Store Directory from old dev file path to new file path
db name\incoming

b. Go to Servers  Output

1. In the properties, go to the Input Filestore Service section Change

2. Temporary Directory from old dev file path to new file path
db name\outgoing\temp

3. File Store Directory from old dev file path to new file path
db name\outgoing

3. Stop SIA on Apps in CCM

4. Backup the CMS and Auditing databases

5. Copy CMS and Auditing backups to new DB server

6. Restore backups to new database with the same name as the existing databases

7. Validate the SIA Agent is still stopped

8. Change ODBC settings

a. BUSOBJECTS_CMS

b. BUSOBJECTS_AUDIT

c. C:\windows\syswow64\odbcad32.exe

a. GO into the CCM

b. Change configuration properties on SIA (specify DB and password)

c. Start SIA on each server

d. Start the CMS service

9. Move Incoming and Outgoing shares onto new db server

10. Validate shared FRS drive is available on new server

11. Restart the SIA

12. Review FileStore for Incoming and Outgoing

13. Set security on file shares

Add a comment
10|10000 characters needed characters exceeded

Related questions

9 Answers

  • Best Answer
    Posted on Apr 04, 2011 at 07:32 PM

    1. BusinessObjects XI 3.1 SP3 FP 3.4

    2. Crystal Reports 2008 3.1 SP3 FP 3.4

    3. Xcelsius Enterprise 2008 3.1 SP3 FP 3.4

    4. SAP Integration kit 3.1 SP3 FP 3.1

    this has to be at the same patch lever as #1

    5. Live office 3.1 SP3 FP 3.4

    6. SAP BusinessObjects Client Tools 3.1 SP3 FP 3.4

    not needed as client tools are part of default server install in #1

    7. Life cycle manager 1.0 SP3 FP 3.4

    8. Data Federator SP3 FP 3.4

    As you're installing on new server, do a default installation with mysql and tomcat.

    Once you have installed all of the above and all is working, then stop default newly installed SIA.

    Stop SIA on your original server.

    Copy FRS (it's not a DB, it's a file store) from original to the new server.

    On new server create new SIA pointing to the same CMS DB as original server.

    If FRS on old server was in the default location - simply start new SIA and you're operational.

    If FRS on old server was in a non-default location - in CMC point new FRS servers to the right location.

    Do update objects.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 14, 2011 at 03:34 PM

    Hi Denis,

    What I did was re-download SAP Integration Kit from SP3 and extracted the sapcrdb_.cab file in question. I found the .dll it was looking for. I replaced that cab file with the existing cab file on my sp3 install and the install worked successfully.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 14, 2011 at 08:44 PM

    Denis,

    I had our DB Team take a backup and create the new DB instance prior to the install. I then copied FRS from the old location to the new location.

    During the install, the option to "Reset Database" could be checked or unchecked. I checked this. Could this be the reason why I'm not able to find the data structure from before? I am having them do a restore now to see.

    Thank you,

    Tereas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2011 at 04:00 PM

    Hi,

    The Update Objects on the CMC doesnt appear to be working for me. When I cancel it runs, but says it has 0+ updates to do. Is this necesary after a DB and FRS move? If so, how do i make it work?

    Thank you!!

    Teresa

    Add a comment
    10|10000 characters needed characters exceeded

    • It is working, what you described is normal, by design, when no objects need updates.

      Update Objects option should be used when you used CMS DB copy process and connecting to CMS DB using newer product version.

      If you copied CMS DB between same patch level of the product - its not needed.

  • author's profile photo Former Member
    Former Member
    Posted on Apr 20, 2011 at 02:43 PM

    OK, everything went well with the install, with the one exception of the Connection Server. I set up a trace and when it fails, it outputs the following:

    kc3cdbtbdacs.cpp:4154:enum ConnectionServer::Status __cdecl tbCnxSrvrRecordSet::doCSExecute(class ibo_ptr<struct IConnectionServer::JobResultSet> &,class std::auto_ptr<class ConnectionServer::ResultSet> &): TraceLog message 1

    2011/04/20 14:02:37.259|>=|E|X| 4492|4672| |||||||||||||||Uncaught Exception in SilentScope: C3_dacs:CSJob::Execute(*Res): 1:1.267

    kc3cdbtbdacs.cpp:3398:long __thiscall tbCnxSrvrRecordSet::StartFetching(void): TraceLog message 2

    2011/04/20 14:02:37.259|>>|E| | 4492|4672| |||||||||||||||**ERROR:C3_dacs:CS::Error (in cancel): (DBD) "[Microsoft OLE DB Provider for SQL Server] : Operation canceled" . [kc3cdbtbdacs.cpp;3398]

    accessRepoProxy.cpp:176:void __thiscall repoProxyAccessImp::ShowError(const class bo_utf8string &,const class bo_utf8string &,int): TraceLog message 3

    2011/04/20 14:17:01.760|>>|E| | 4492|6360| |||||||||||||||Error! repoProxyAccessImp::getUniverseSecuriteInfo() : [repo_proxy 36] UniverseFacade::getUniverseInfo - ISInfoObject has not been found

    I've upgrade QA already with the same one bug, and also found that the build versions dont display. Although the build version is accurate on the executables, the actual "about" is not. I found the following 2 notes and opened a message with SAP. I hope we can get the connection server resolved.

    1559906 - Connection Server can't start after upgrading BusinessObjects Enterprise XI 3.1 from SP2 to SP3

    1516727 - Desktop Intelligence product number does not upgrade when applying FixPack on BusinessObjects Enterprise XI

    So, at this time the only configuration challenge I'm facing is within the dashboard &Analysis area. I get the PMUser error. I found this also exists in Production, which hasnt been upgraded. Is there an effecient way to resolve this? I do see the user set up as an ADMIN.

    The PMUser account is missing or corrupted. (EPM 03007) AA2209

    Enterprise authentication could not log you on. Please make sure your logon information is correct. (FWB 00008)

    Thanks for reading. I'm learning alot with this upgrade and able to resolve some errors more quickly now. Your responses and knowledge is very appreciated.

    Teresa

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 13, 2011 at 09:35 PM

    Hi Denis,

    Im having trouble completing the install for the SAP Integration Kit XI3.1 SP3. I've saved the sapjco.jar and dll files to their respective locations. However i get this erorr

    Error 1334 where it cant find the crdb_bwmdx_res_en.dll in the sapcrdb_.cab file. I didnt see it there either. Does SAP have a pre-install step for this?

    Thank you so much for your review.

    Teresa

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 13, 2011 at 11:59 PM

    I found this note, so im going to try it and see what happens.

    1574460 - Incorrect data in Crystal Reports with more than PacketSize records from BW via MDX after updating Transports

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 14, 2011 at 08:03 PM

    Hi Denis,

    I've finished the Install successfully. However, after I run the update objects in the CMC on the new server, it says there are 0 updates, then it runs. The folders are not showing up. The other issue i see is the connection server in the services on the CMS is not running and fails to start.

    FL1DVMBOBJ01.ConnectionServer

    This server is considered failed because it has stopped 5 time(s) in 60 minute(s).

    ID, CUID: 829 , AS_0SabFU9JEjLQ_YQfdhUc

    Node: FL1DVMBOBJ01 (FL1DVMBOBJ01, !boxidev.svc)

    -fg -restart -name FL1DVMBOBJ01.ConnectionServer -ns FL1DVMBOBJ01.hq.chicos.com:6400

    These are the only error logs i can find:

    2011/04/14 19:47:16.610|>>|A| | 2960|3404| |||||||||||||||assert failure: (.\ObjectSubsystem.cpp:5175). (collateHelper != NULL : no message).

    .\ObjectSubsystem.cpp:5175: TraceLog message 27

    2011/04/14 19:47:32.418|>>|A| | 2960|3524| |||||||||||||||assert failure: (.\ObjectSubsystem.cpp:5175). (collateHelper != NULL : no message).

    Can you provide any assistance or feedback?

    Add a comment
    10|10000 characters needed characters exceeded

    • Update objects found no objects needed updating, that's good then you click on Cancel and it runs and finishes - that's normal.

      Which folders and where not showing up ?

      Is FL1DVMBOBJ01 your new server or original ?

      Try creating a new one in CMC.

      You might want to consider opening a support case to go over all the steps you did and to make sure nothing is being missed.

  • author's profile photo Former Member
    Former Member
    Posted on Apr 14, 2011 at 08:10 PM

    all folders (Custom), developed universes, and connections are not showing up. Yes FL1DVMBOBJ01 is the server. I have the older development server still but turned off all services.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.